2 years, 1 month ago.

Unable to download hex file to nRF51822 board

I have now wasted several hours trying to get the blinky example to work on the board, but it appears that there is some severe issues with downloading the hex file to the board.

I'm using an HP laptop, with Windows 10, and whenever I connect the board the MBED disk is mounted, only to be ejected shortly after, and then mounted and ejected again. This repeats forever.

If I try to copy the hex file to the board, it frequently gets to around 94%, and then fails.

When I first connect the board there is no fail.txt file on the device, but after it has been automatically ejected and remounted, there is a fail.txt containing "TIMEOUT".

I have tried attaching it through a USB 2 hub, in case the issue is related to the USB 3 ports on the laptop, no difference. A colleague has also tested the board, same issue.

I tried it on an elderly MacBook Pro, running MacOS Sierra, and it worked on the first attempt, and I tried to write the flash several times, no issues at all, and the board starts the blinky app whenever I attach the USB cable, just as I would expect.

I then tried it on a x64 system running Solaris 11.3, on both USB 2 and USB 3 ports, and also on one of the USB 2 ports on a Sun Ray connected to the system, same issue as with Win 10.

It appears that the board for some reason believes that it should reprogram the flash when it just gets connected to USB as the blinky app that I could program on the MacBook, and that started automatically whenever I disconnect and reconnect it onthe MacBook, stops working after just being connected to the win laptop, and the fail.txt file gets created.

Does Windows and Solaris issue some command to the board that is misinterpreted as a write request?

I've also tested a nRF52-DK board, and it has no issues at all.

Question relating to:

The nRF51822-mKIT is a low cost ARM mbed enabled development board for Bluetooth® Smart designs with the nRF51822 SoC. The kit gives access to all GPIO pins via pin headers ...
Comment on this question

2 Answers

2 years, 1 month ago.

I'm having the exact same issue.

Did you solve it?

I'll see how it works after another update attempt and some other tricks I've found.

No, I haven't done any more work on it. I'll give it a try on some other systems I have access to, but there is clearly an issue with the disk emulation on the board.

posted by Thomas Törnblom 29 Aug 2017
2 years, 1 month ago.

There is an issue on Windows 10 with old versions of the interface firmware.

To solve it you can either download the latest version of mbed dap link and use it or use the JLINK firmware

None of these seems to fit on the board. I get an error saying it needs about 60k additional space.

I installed nrf51822aa_atsam3u2c_if_mbed_V0218_19022015.bin a few days ago, and it is 34k. The files you mention are around 108k .

Or is there some other process to install these firmware files?

posted by Thomas Törnblom 29 Aug 2017

The JLINK should fit, same for 0243_sam3u2c_mkit_dk_dongle_nrf5x_0x5000.bin .

What version of the board do you use ?

posted by Vincent (pan-) Coubard 29 Aug 2017

There's a sticker on the board saying: PCA 10024 V 1.0.0 2014.26

I tried copying the JLINK file to the board in firmware update mode using the MacBook, and it also says that there is not enough room. Get Info on the device says there is 45k available, and that 2k is in use.

I tried copying the Blinky hex file to the board using a Raspberry PI 3 B, and it worked right off the bat.

posted by Thomas Törnblom 30 Aug 2017

Now I understand, your not speaking of the NRF51822 micro on the NRF51_DK board but the NRF51822 board.

This board is not supported by mbed OS 5 and mbed OS 2 support is minimal.

Unfortunately I don't think there is an existing solution to your issue.

posted by Vincent (pan-) Coubard 30 Aug 2017

You need to log in to post a question