Report
2 months, 1 week ago.

Zoltan Hudak / UIPEthernet enc28J60 lib TCP not working

Hi, I am trying out Zoltan Hudak / UIPEthernet TCP client lib with nrf51-DK.I tried UDP it worked but TCP is not working Iam using socket test v3.0.0 for TCP server in my lap. I couldnot figure out what is the issue,why I couldnot communciate.

Server IP : 192.168.3.230 Local Ip : 192.168.3.9 Port : 10001

Can anyone help how I can resolve it.I can ping the IP but couldn't establish TCP connection.

Thanks, E.K

Hello Karthick,
Thank you for reporting the issue. It's strange. When I create a UIPEthernet TCP server and a UIPEthernet TCP client then everything works fine. But when the TCP server is running on a PC then the UIPEthernet TCP client fails to connect to the server. I'll let you know once it's fixed. I'm sorry for the inconvenience.
With best regards, Zoltan

posted by Zoltan Hudak 11 Aug 2017
Comment on this question

1 Answer

2 months ago.

Hello Karthick,

Check your Firewall settings. I have tested the UIPEthernet TcpClient demo with a TCP server running on my PC recently and it worked fine (I turned the Windows Firewall off on my PC while performing the test). Or you can try to build a TcpServer demo on an another MBED board (there will be no Firewall between the client and server in this case) and the communication should work as well.
With best regards, Zoltan.

Hi Zoltan Hidak, Thanks for your reply.I tried turning off my firewall but no luck,Can you tell what TCP server software you run in the PC.I shall try the same here.

posted by Karthick E 14 Aug 2017

Hello Karthick,
To build a TCP Server for testing I created this project using the Qt Creator IDE. However, to test only connection you don't have to build your own TCP Server. Instead, you can try to connect for example to the "Eclipse Paho MQTT server". Just modify line #62 in the main.cpp of TcpClient demo as follows:

            if (client.connect("m2m.eclipse.org", 1883)) {
posted by Zoltan Hudak 14 Aug 2017

To post an answer, please log in.