2 years, 11 months ago.  This question has been closed. Reason: Too broad - no single answer

Semi-unresponsive mbed

I have semi-unresponsive mbeds.

Symptoms: 1) As a USB drive, the mbed seems to be operating normally. I can copy files with no problem. 2) All LEDs appear to be dimmed (with or without a program loaded). No change in LEDs when I try different USB cables and different PCs. 3) I have tried to run the newest blinky program with no success (file copies over and I press reset with no success). 4) I have tried to install a previous version of the firmware with no success (I check the HTM file link for firmware version).

I have thus far corrupted numerous mbeds (eight) in trying to figure out what is going on. The mbeds are removed from any circuitry. Prior to re-programming some of the mbeds with the new blinky program, the previous loaded programs were working.

I have followed the dead mbed procedure (formatted drive even restoring the usb).

I am fairly certain that this is a configuration/software issue as the mbeds are removed for any circuitry.

Any suggestions on further debugging?

2 Answers

2 years, 11 months ago.

Matthew, That sounds like a highly unlikely situation...

However, the question platform is not really the right place for a discussion like this.

However, I will pop the questions below, but may I suggest that you start a new forum discussion with at least the 4 questions below answered.

1. What were the 8 mbed target boards that were "corrupted"?

2. How do you tell that they are corrupted?

3. What were the different PCs (and their operating system versions) that you have tried?

4. Is there a chance of a common element, such as a bad USB cable or a bad USB hub?

Thank you for responding and I agree that is highly unlikely. I have worked successfully with these boards for over two years. I will move over to forums with answers to your questions. 1) Target boards are the LPC1768. 2.) I was using the LEDS for debugging when I could not get any response. I started reverting to more simple programs eventually ending at the blinky program that would not respond. 3.) a) Microsoft Surface Pro Windows 10.0.15063 and b.) Dell P49G Windows 10.0.15063 which both have worked previously. 4) I have tried six different USB cables in the different usb ports across the two machines.

Even if I cannot recover, I do not wish to repeat whatever I did. Regards, Matt

posted by Matthew Feemster 31 Jul 2017
2 years, 11 months ago.

Hello, you don't specify what is your operating system and your non responsive board('s).
Let me guess... if you have Win10, after an infinite series of upgrades....you may facing with problems with the indexing service of windows that tries to write something like 'System Volume Information folder ' on your mbed board....
I resolved this disabling that 'service :-)' using regedit , browsing to following key:
'HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search'
adding an dword value with name:
'DisableRemovableDriveIndexing' and value: '1'
restart windows and reload mbed firmware
I found this page with step by step instructions. Note that first method esplained with windows global policy editor - GPEDIT is not working on home edition of w10 so you have to jump at regedit solution in that case
http://www.thewindowsclub.com/prevent-system-volume-information-folder-usb