5 years, 1 month ago.

File "ChannelPlans.h" missing

In order to test my xDot kit I have followed the intructions in https://developer.mbed.org/teams/MultiTech/code/Dot-Examples/. I have imported Dot-Examples program and libxDot-mbed5 library into mbed compiler and checked that the correct version of mbed-os is selected (5.4.2). But when I try to compile, I get the following error:

Error: Cannot open source input file "ChannelPlans.h": No such file or directory in "examples/inc/dot_util.h", Line: 6, Col: 27

Am I missing something?

Question relating to:

The MultiConnect® xDot™ is a low cost, low power LoRa Module.

1 Answer

5 years, 1 month ago.

Alejandro,

Our build automation system wasn't picking up a couple new source files. I think the issue should be resolved now. Please try the latest version.

Cheers,

Mike

Accepted Answer

The development library is compiling ok now. Thanks

posted by Alejandro Veiga 20 Jun 2017

I've just tried it (imported Dot Examples, plus libxDot-mbed5), getting the same error...?

posted by Andrew Starr 21 Jun 2017

Andrew,

libxDot-mbed5 is our production build and wont' be updated to version 3.0.0 of the dot library until we actually release. You can use the dev version of the library or roll back the Dot-Examples.

Cheers, Mike

posted by Mike Fiore 21 Jun 2017