3 years, 5 months ago.

Nucleo F446RE no IRQ on all pins

Hi all !

Well I've tried to get an interruptIn on PA_12 but PA_12 don't see rising or falling edge of my signal even when I add an enable_irq.

Does anyone have an idea of how to activate IRQ on PA_12 (event without Mbed HAL) ?

Thanks.

1 Answer

3 years, 5 months ago.

You already asked it here: https://developer.mbed.org/questions/78137/It-looks-like-PA_12-cant-be-an-Interrupt/

There is the correct answer. Have you tried to remove interrupt from PB_12 pin? (InterruptIn Echo3 (PB_12);)

Also see 12.2.5 External interrupt/event line mapping (page 382) here: http://www.st.com/content/ccc/resource/technical/document/reference_manual/3d/6d/5a/66/b4/99/40/d4/DM00031020.pdf/files/DM00031020.pdf/jcr:content/translations/en.DM00031020.pdf

Accepted Answer

I also need an IRQ on PB_12 so removing one to activate another is not a solution. I gonna read the User manual to find out if there is a way to solve the problem. Thanks a lot.

Sorry for double post. The first doesn't appear in my dashboard.

posted by H A 27 May 2017