4 years, 4 months ago.

Having trouble talking to mDot over USB

Hi,

I am having trouble connecting over usb. I can successfully get the led blinking, but through Putty I can not get any commands or text to show up. It is simply blank.

Steps I have taken:

1. Install ST-Link Driver 2. Install blinky program, works 3. Install AT command software. It installs, but when I connect through putty, I get a blank command window. 4. Try programs with simple printf functions. Same result as above. 5. I have tried various programs, firmware and drivers. Can't get any luck with the command window.

I have tried on both windows 7 and 10. I cannot get the Windows-Serial-Configuration program to run. Always says no mbed found. Although it says you do not need it on windows 10. This is probably part of the problem.

Using the mDot MTUDK2-ST-MDOT Also what AT firmware should I use. 1.0.8-1 or 2.0.16

Thanks a ton.

UPDATE: Think I found part of the cause, every time I load the file onto the multitech mdot. It reboots, and the file isn't there. I believe it is suppose to be there. Oddly the blinking led part of it still works. Thanks

posted by Dean Simonelli 17 May 2017

1 Answer

4 years, 4 months ago.

Hi Dean,

In regards to your comment "UPDATE" - THis is how mbed is supposed to function, when the device is flashed with a new file, it simply reboots and it will be blank, its waiting for another potential file, the program you flashed on the device is now running though, so there are no issues here.

In regards to the main question. There should be two serial COM ports for this, one for AT commands and one for USB serial logging.

If you want to do general USB serial logging, you need to choose this one.

You also need to make sure you have the correct baud rate for the device, if nothing is specified it is 9600.

Have a look here for more info. https://developer.mbed.org/teams/MultiTech/wiki/mDot-AT-Command-Quick-Start

When flashing the device are you using the correct serial "(USBTX, USBRX)"?

Are you mounting the device properly, i.e. power the device first, and then the USB of the kit?

Regards,

Andrea, team mbed

Accepted Answer

My kit did not include a power supply. So I have not been using one, although I just plugged one in, and I am getting the same result. Also power supply doesn't turn on the power LED, only the USB is turning that on.

In regards to the AT serial port. I have tried using that COM and same result.

Also when I plug into the serial port. The D0 LED lights up, I hope this means everything is good with my serial to usb cord.

UPDATE: Tried using windows 10 and I am able to type in the console. Although the characters are not what I type, it's progress! Currently trying to figure this out. D3 LED comes on at start fyi.

UPDATE2: Device works the same without power supply, still no keys matching.

FINALLY: It was my serial cable. It's working now. Thanks.

This is the mdot I'm using. https://developer.mbed.org/platforms/MTS-mDot-F411/

posted by Dean Simonelli 17 May 2017