7 years, 4 months ago.

KL25z USBSerial not working

Hello mbed-team,

I tried the USBSerial example in the Handbook with the Freedom-board-nothing happened. I used different setups: only the Debugging/flash USB connected, only the second USB connected, both connected - nothing worked. Before compilin, I changed the Build option to the Freedom board. Other code examples, e.g. blinking LED, work fine. Using realterm, I see that a virtual serial port has been created, but it does not transmit data.

Is this a bug in the library, or is this due to missing jumper setting etc.?

Thank you very much in advance,

Tobias

2 Answers

7 years, 4 months ago.

Hi,

I just tried using it with teraterm and it is working fine for me. When you plug the second USB connector, there should be a new serial port created called "Mbed Virtual Serial Port". Have you installed the .inf file for the serial driver?

Can you try with teraterm to see if it works?

Cheers, Sam

7 years, 4 months ago.

Hi!

I use Windows 8. Here are the devices as they are recognized by the system:

mbed Serial Port 8 (This is the port used for programming at that emulates UART communication) USB Serial (Communication Class, Abstract Control model) COM 7 (This is the USB port where I expect to see the text fragments)

I use Realterm (for more than a year, and I am 100% shure that this Software is OK...)

I try to change the driver.

No, still doesn't work... Is there any update to the mbed library required, firmware update...?

posted by Tobias Piroth 05 Apr 2013