7 months, 1 week ago.

FRDM-KL25Z mount/unmount latest to fail Win10

FDM-KL25Z is the latest board I've tried on Win10 (several machines) that constantly cycles through mount/unmount. Win7 works fine. Firmware has been upgraded to the latest. Autoplay has been turned off. This is just so infuriating!!

FRDM-K64F did it for a short time, but found out it had older firmware and it stopped after upgrading to the latest. uBlox-C027 still does it to this day. Nordic boards (Dk51 and DK52) seem to be working. STM 427 based board sort of works (I have to remove USB power each time I load app, so I don't like using it).

Comment on this question

2 Answers

7 months ago.

You can try the link from the answer here: It shouldn't be required with the latest firmware on the KL25z, but it might help. By the way, are you sure you run the latest firmware?

The link was very useful and appears to have solved my problem. I'm surprised I have not seen this suggested fix since now. It should be linked from the main mBed troubleshooting page.

posted by Steve Martin 15 Mar 2017

Agreed, I have asked for that to happen, didn't happen yet. I can ask someone else to try to have it added again.

posted by Erik Olieman 16 Mar 2017
7 months ago.

Did you try the DAPLink firmware here?

I've only tried the latest version linked in the handbook ( Are these separate efforts?

posted by Steve Martin 15 Mar 2017

The DAPLink is new version of CMSIS-DAP interface firmware which support latest host OS include Windows 10.

You can download zip archive here and find 0243_k20dx_frdmkl25z_0x8000.bin file. Firmware flash instruction is same as before.

posted by Toyomasa Watarai 16 Mar 2017

To post an answer, please log in.