6 years, 7 months ago.

Problem with the mbed CLI compiler

Along with the stressful situation of the online compiler, I have been trying to get familiar with the offline compiler mbed CLI, I followed all the steps. However, when I got to the last step that is compiling the program, I receive the error that you can see in the image attached.

Please give me a help. /media/uploads/yacine1991/mbed-cli_wTdsSmt.jpg

I just figured out that the Servo.h library is not included in the mbed libraries so I have to include it separately. I did but still getting the same error.

posted by Yacine Bougrinat 20 Feb 2017

1 Answer

6 years, 7 months ago.

It looks like an escaping issue. Can you wrap the GCC_ARM path in double quotes?

Accepted Answer

Here it is: "C:\Program Files (x86)\GNU Tools ARM Embedded\4.9 2015q3" The toolchain is for 32-bit win and I have a 64-bit win, could that cause problems ?

posted by Yacine Bougrinat 21 Feb 2017

Should not be the case. Maybe add that folder to your PATH and not set the toolchain location from mbed CLI... Or if all fails, put the toolchain in a path without spaces ;-).

I'm on Windows 7 and have GCC_ARM in my path and that works pretty reliable.

posted by Jan Jongboom 21 Feb 2017

Thanks Jan, but I am little confused here, because when istalling I followed the official installation guide ( https://www.youtube.com/watch?v=cM0dFoTuU14 ) and it seems he used the default path which is the same as the one I used. So should I reinstall it and put it in a different path ?

posted by Yacine Bougrinat 21 Feb 2017

If you run `where gcc-arm-none-eabi-gcc` in a command window does it return something?

posted by Jan Jongboom 22 Feb 2017

if I run "arm-none-eabi-gcc -version" inside the path I mentioned it gives the thing it is supposed to give (as shown in the tutorial video) the only difference is that in the tutotial he runs this command in the path: "C:\Users\ARM". So do you suggest I reinstall the toolchain in another folder (not the default one I am using now) ? /media/uploads/yacine1991/mbed-cli_RPRZ4qL.jpg

posted by Yacine Bougrinat 22 Feb 2017

Not sure what's happening. I'm running the toolchain from a path with spaces and that works fine... But moving it to a non-spaces path might help.

posted by Jan Jongboom 22 Feb 2017

Thank you Jan! I removed all the spaces in the path folders names, then, it worked !

posted by Yacine Bougrinat 22 Feb 2017

Can you explain it to me ? I've the same problem

posted by jefferson Romero 28 Mar 2017

@Jefferson Romero, move the folder that holds arm-none-eaib-gcc to a path without spaces, e.g. C:\GCCARM\.

posted by Jan Jongboom 28 Mar 2017

I don't get it , i have a folder in that route : "C:\Program Files (x86)\GNU Tools ARM Embedded\4.9 2015q3\arm-none-eabi", What do I have to change?

posted by jefferson Romero 29 Mar 2017

Make a new folder: C:\GCCARM. Copy the content of "C:\Program Files (x86)\GNU Tools ARM Embedded\4.9 2015q3" into "C:\GCCARM". Then add C:\GCCARM to your path.

Not sure why this would work, but it helped the previous questionee... It works fine on my machine with spaces...

posted by Jan Jongboom 29 Mar 2017

¿what do you mean by "path"? ¿what folder does "path" refer to?

posted by jefferson Romero 30 Mar 2017