Report
2 years, 2 months ago.

Darn Win10 continuously generate SWD error on my KL46Z

Hi all,

I use a Win10 computer, running TeraTerm. The Indexing thing in the Win 10 continuously breaks the KL46Z board. Even if the firmware is uploaded in Linux, and working OK, when I plug the board on win 10 computer, it breaks the board with the error.txt file yelding a SWD error. Then allso the .bin file can not be uploaded anymore. Sometimes it works Ok, sometimes it does not, however I never faced such problem in Linux. Unfortunatelly using linux on my work machine is out of question. What can I do? I have the latest bootloader FW installed on board, i use Windows 10 Version 1607 (up to date).

Regards,

GR.

Comment on this question

1 Answer

2 years, 2 months ago.

With the latest bootloader, do you mean the latest mbed firmware or the latest PE Micro bootloader? Since especially latest mbed firmware is important, although you can't install that without latest PE Micro bootloader, unless you have a W7 or earlier PC, or the disable the problematic part in W10, which might help anyway with preventing your issue.

To do this, see: http://www.thewindowsclub.com/prevent-system-volume-information-folder-usb

Erik hi,

yes by latest bootloader I meant the latest mbed firmware. This problems occures only on win 10 with 1607 version. I could disable the system volume indexing on my computer, but this is not a suitable solution. I move my mbed based devices on several computers.

posted by Gorazd Rosbach 06 Feb 2017

What do you mean with 1607 version? Latest KL46z I see is 0203 version. Personally I disabled the system volume information thing on all my PCs for flash drives, but I can understand if you move between many PCs, and not all your own, that could be problematic.

posted by Erik Olieman 06 Feb 2017

Obviously (or perhaps not) he means the 1607 version of Windows 10 - aka the "anniversary update". That broke several things when it hit my PC, but nothing related to MBED, at least, not that I have noticed yet.

posted by Andy Wood 06 Feb 2017

That wasn't obvious to me, since I do know about anniversary update, but not the type numbers of it ;)

posted by Erik Olieman 07 Feb 2017

Disabling System Volume Information folder creation on USB actually solved the problem on my work computer. Yes, by 1607 I meant the anniversary update of Win10. We had a lot of problems caused by this update, the biggest was that windows could't deal with FAT12 and FAT16 FS, so sveral embedded systems were useless. MS then released a patch, but not everything was patched correctly. Mbed is one of those unpatched things. Anyway, thank you for the link, that solved my problem. Regards, GR

posted by Gorazd Rosbach 07 Feb 2017

To post an answer, please log in.