2 years, 10 months ago.

SOLVED: LPC800-MAX bricked after an upgrade

Workaround: Do theu pgrade from Windows, not from Linux. -

Hi,

I was using such a board since 2 years ago, and today that I applied an upgrade the mbed disk stop appearing in my Linux box. I followed these instructions:

https://developer.mbed.org/handbook/Firmware-LPC800-MAX

Whenever I reconnect the board to the PC nothing appears, only when I plug it pushing the reset button I get the "CRP DISABLED" disk with the 'firmware.bin' file on it. I guess I got a brick.

I've followed some workarounds that I found on internet, but none of them has worked.

There exist some official workaround? Thank you!

Xavier,

Have you tried this on another PC? Does it ever appear, have you tried updating on another PC/OS?

Regards,

Andrea, team mbed

posted by Andrea Corrado 16 Jan 2017

Thank you for your prompt reply! It was an issue regarding to Linux. While my main workstation is based on LinuxMint 18.1, I also have a W10 in a partition on my Laptop. So I tried the whole process described on the mbed link in the Dell's laptop factory installed Windows10 (I don't know which update or so because I'm not user of it) and it worked. I recovered my LPC812-MAX board!

Being such a frequent source of problems there should exist an official workaround for Linux users. Hopefully I left W10 installed on my laptop, otherwise I wouldn't be able to do anything else (take into account that some rebelds don't use neither W10 nor Mac).

Anyway, I'm very pleased with the NXP microcontrollers and the customer services. Kind regards!

posted by Xavier Rguez 16 Jan 2017

Brilliant, thanks for the update. Glad to see it back online :)

Regards,

Andrea, team mbed

posted by Andrea Corrado 17 Jan 2017
Comment on this question
Be the first to answer this question.

You need to log in to post a question