2 years, 10 months ago.

Export to IDE still not working

For weeks now I have been trying to export the simplest of programs: nucleo-blinky on STM32F401 or F446. It never works. After reading several other posts about this, I have tried all times of day and night, and from various host machines. I have tried to export this program with the normal mbed libraries, and with the mbed-dev source code libraries. The export always fails. I have tried to export any number of other programs too. Since September last year I see no evidence that anyone is working on this. It is important to me and perhaps to others because I did all of my prototyping using mbed, but now want to move my code onto my production circuit board, which is not mbed compatible.

Comment on this question

3 Answers

2 years, 10 months ago.

Hey Bill, Sorry you're having trouble exporting.

Which IDE are you trying to export to?

If the online ecosystem is not working, you could "import with mbed-cli" and `mbed export` from there.

Not clear to me how to use the mbed-cli for this problem. In particular, where is my program? I don't know if I need to commit it, for example, or what I need to do to make it visible to me from mbed-cli. Also, I seem to be 3/4 done with installing mbed-cli and haven't worked through to completion yet.

posted by Bill Den Beste 12 Jan 2017

I answered via gmail, but that might not work, so here is what I sent:

I read all of the previous bug reports about export, and tried any of the variations that were suggested as answers. I've done quite a bit of testing. Tried the nucleo blinker project on the STMF401. Tried exporting the project with mbed-dev and with mbed as a library. Used Chrome, Firefox and Safari browsers. I tried all available export IDEs too. Tried during the day and in the middle of the night. No difference. All of the above failed.

Then I tried a simple app (nucleo ticker) on the STMF030R8 platform and was able to export the project. I now think that my issues related to the STMF4 series devices and export and that the issue is not about the target IDE or about a server timeout. Of course, I could be wrong....

All I need is a sample program using the STM32F446RE that uses DigitalIn, DigitalOut, AnalogIn, Serial, wait, and ticker. Perhaps a couple other simple classes that I have forgotten. I am using Atollic TrueStudio V7.01 but I think I know how to get there from GCC ARM embedded.

Forgot to add SPI and SDFilesys to my list of mbed classes.

Thanks for the quick initial response

posted by Bill Den Beste 12 Jan 2017

In particular, where is my program?

That depends. If it's only on the online compiler, you may have to publish the program. After your program is published it will have a dedicated project page. That project page will have a button that may be switched from `import into online compiler` to `import with mbed-cli`. The `import with mbed-cli` button will give you the full command line to get a copy of your example locally.

Some links that may be of help to you: https://github.com/ARMmbed/mbed-os-example-blinky/ - contains instructions to import with mbed-cli. https://github.com/ARMmbed/ci-test-shield - not really an example, but does contain tons of code that covers most of your use case. https://github.com/ARMmbed/mbed-cli - Just in case you don't already have this link to the readme for mbed-cli

posted by the other jimmy 13 Jan 2017
2 years, 10 months ago.

HI, I have been working toward going offline for many months. I have found that in the uV5 c/C++ target options, it seems to work best if you add -O3 on the end of the misc text.

but printf doesn't work, it is a disaster.

can someone please help me understand how to fix this ? << code>>

* Using Compiler 'V5.06 update 4 (build 422)', folder: 'C:\Keil_v5demo\ARM\ARMCC\Bin' Build target v compiling printf.cpp... printf.cpp: 0 warnings, 0 errors linking... .\build\uvision5\v.axf: Error: L6218E: Undefined symbol thunk{-68} to mbed::Serial::lock() (referred from printf.o). .\build\uvision5\v.axf: Error: L6218E: Undefined symbol thunk{-68} to mbed::Serial::_getc() (referred from printf.o). .\build\uvision5\v.axf: Error: L6218E: Undefined symbol thunk{-68} to mbed::Serial::_putc(int) (referred from printf.o). .\build\uvision5\v.axf: Error: L6218E: Undefined symbol thunk{-68} to mbed::Serial::unlock() (referred from printf.o). Not enough information to list image symbols. Finished: 1 information, 0 warning and 4 error messages. ".\build\uvision5\v.axf" - 4 Error(s), 0 Warning(s). Target not created. Build Time Elapsed: 00:00:02 <</code>>

Off topic. This thread is about export as an mbed operation that does not work.

posted by Bill Den Beste 20 Jan 2017
2 years, 10 months ago.

Ditto Bill, very frustrating!

What is really frustrating is that mbed seems like a black hole. I don't see any evidence that this problem is being worked on, or has been queued up to be worked on in the future, or that this feature has been targetted to become obsolete. Knowing any of those would help me decide what to do next. Instead, all that I can do is try to figure out how to get along without this feature. I fear that without some kind of processes that are visible to mbed users, this whole house of cards will someday come falling down. mbed is too good of a concept for that to happen, but that won't be enough to save it if there are no processes for managing the complexity.

posted by Bill Den Beste 20 Jan 2017

I have abandoned mbed, ST32-HAL-uV5 seems to work well. Although mbed is super easy to implement there is no security online and little support to get offline.

posted by Nick Marsh 20 Jan 2017

You need to log in to post a question