Report
2 years, 6 months ago.

Nucleo boards do not work with Windows 10

I use 3 Windows 10 64 bit computers with Nucleo F401RE, F411RE, F302R8 and L152RE. Two of the computers could connect to the boards, so I could updated ST-LINK firmwares to the newest.

  • First problem: The connection is not stable, the debugger occasionally resets target. I tried debugging with Keil and with CoIDE. There is no problem with separate (Not Nucleo) ST-LINK V2.
  • Second problem: After 10-15 uploads, the ST-LINK interface and the ST virtual serial port become inaccessible. They are visible in the device manager, but the softwares could not connect to them and the MBED drive is empty or inaccessible. The only help is to restart computer.

On the third computer, there is no initial successful connection, just error.

Nothing helped. Standalone ST-LINK V2 works well.

/media/uploads/vargham/2017-01-11_07_54_55-mbed.png Devices show up in device manager but could not connect to them.

Downloaded 2.28.18. This time I tried the Java version. It lists the ST-LINK interface. /media/uploads/vargham/2017-01-11_17_34_31-stlinkupgrade_3.2.2.png

Windows device manager: "This device is working properly."

I clicked "Open in update mode"

/media/uploads/vargham/2017-01-11_17_35_10-stlinkupgrade_3.2.2.png

Windows device manager: "Windows has stopped this device because it has reported problems. (Code 43) A request for the USB device descriptor failed."

Comment on this question

4 Answers

2 weeks, 1 day ago.

Make sure you are NOT using a Hub. ST-Link will not work, e.g. with an Amazon basics HUB. Wasted too much time on this one.

2 years, 6 months ago.

Hi,

Can you try to update your board with the latest STLinkUpgrade (V2J28M18) and check again ?

http://www.st.com/content/st_com/en/products/embedded-software/development-tool-software/stsw-link007.html

Scroll at the bottom.

Regards

Thanks. I tried it with 6 different boards. I put the details into original question.

posted by Mark Peter Vargha 11 Jan 2017

I use the newest firmware on all of the boards. No luck, none of the V2-1 works. It might be a driver conflict, but I could not find the root cause. Older Discovery boards with V2 and stand alone ST-LINK V2 without USB drive emulation are working fine.

posted by Mark Peter Vargha 23 Feb 2017
2 years, 6 months ago.

All seems to work for me and my DISCO_F746NG (with STLINK V2-1) board with mbed after the DISCO was upgraded with the latest firmware.

2 years, 6 months ago.

I have Win 10, I have tried about 10 different Nucleo/disco boards.

they all work

I found that the Nucleo - USB connection needs to be power cycled sometimes.