3 years, 11 months ago.

Nucleo F303k8: Program don't work if I compile with GNU Arm Toolchain

Hi.

If I compile the sample project "Display a message on PC using UART" with online compiler, it works. If I export the project for "GNU gcc Embedded" and compile with arm-none-eabi-gcc 6.2.0 , however, the program dont' work. The LED don't blink. Nothing is sent with UART.

Can anybody help this?

Thank you.

Hi Yoshitaka,

Sorry for the issues you are having.

Have you tried to compile with our offline toolchain mbed cli? https://github.com/ARMmbed/mbed-cli

You will be able to import your previous examples and projects and also compile for GCC.

If you need any help with this let me know :)

Regards,

Andrea, team mbed

posted by Andrea Corrado 06 Dec 2016

Hi Andrea,

I installed mbed-cli and worked !! Thank you so much for your quick reply! I'm a programmer and I love to use command line. So, I'm very happy that I can develop with cli tool.

However, I don't need operating system on my nucleo. I'm going to use nucleo for simple, no-multithreaded task, which is able to be done without operating system. I don't want to use Flash and RAM for unnecessary things. It would be great if I can use this command line tool without mbed-os. Is it possible?

Best regards, Yoshitaka

posted by Yoshitaka Taguchi 07 Dec 2016

H Andrea,

According to mbed cli, the Nucleo F303K8 is not supported. Could you please help me get working on mbed cli?

posted by Numan Jan 07 Feb 2017
Be the first to answer this question.