3 years ago.

Problem with CMSIS-DAP Debugger (RDDI-DAP Error)

Hi everyone,

After following the guide and following solutions on forums with people with this same error, I am still unable to use the CMSIS debugger on my LPC11U24 board, I keep getting an RDDI-DAP Error.

I followed everything on this link 'https://developer.mbed.org/handbook/CMSIS-DAP-MDK'. I installed the latest firmware for my device. Installed the latest serial driver with my mbed plugged in.

When I go to devices and printers, I can see: MBED Serial port (COM), MBED USB Device, and finally MBED CMSIS-DAP which agrees with what the handbook says.

I'm operating on x64 Windows 10.

If any other information is required please ask!

Also apologies if this has been answered before and I missed it, I feel like I have read absolutely everything on this topic online but still no biscuit!

Comment on this question

1 Answer

2 years, 9 months ago.

There have been a few situations that cause this error:

1) https://developer.mbed.org/questions/764/RDDI-DAP-error-by-keil-uVision-and-CMSIS/ Resolution was to upgrade mbedWinSerial drivers

2) https://mcuoneclipse.com/2013/10/22/using-the-frdm-kl25z-with-cmsis-dap-to-program-non-freescale-arm-microcontrollers/ Issue and resolutions in forums was to select both SWJ and SW inside CMSIS-DAP's target driver setup and attempt to reconnect USB to board. I also had to reset my TWR board after reconnecting, before a connection established to the target device.


You need to log in to post a question