4 years, 9 months ago.

demos not compiling

several of the demos are giving me the following error. I have not been able to track this down. Error: Cannot open source input file "stm32f7xx_hal.h": No such file or directory in "BSP_DISCO_F746NG/stm32746g_discovery.h", Line: 48, Col: 28

any suggestions Thank you

Question relating to:

The STM32F746G-DISCO discovery board (32F746GDISCOVERY) is a complete demonstration and development platform for STMicroelectronics ARM® Cortex®-M7 core-based STM32F746NGH6 microcontroller.

I found this demo https://developer.mbed.org/teams/ST/code/DISCO-F746NG_SD_demo/?platform=ST-Discovery-F746NG Which did not compile but for other reasons. If it is the same as you are trying I would post a comment on the Github website. As far as the clock, I found a demo with the RTC which worked without issue.

posted by Bill Bellis 21 Oct 2016

3 Answers

4 years ago.

Hi, This problem can be found in evaluation version of Keil MDK or IAR You can use free compilers

Hi sajjad, do you have any idea about FAT file error? I could not able to load any image to STM32f746ng. If you have any example code for SD card please help.

posted by Ruchit Kasa 23 Jul 2017

You can use free app STM32CUBEMX and this app has many examples like uSD and LCD , etc

posted by Sajjad Alavi 23 Jul 2017
4 years, 9 months ago.

Can you be more specific on which demos are not working? It sounds like there might be a mismatch with the mbed lib and the latest release. You can try updating all libs and see if it compiles. I'll be glad to try on my board once I know which demos you are trying.

Thank you for your responce. The two that I am having trouble with are the clock demo and the sd demo. I just tried to update them both. with no success. I have also removed them and and reloaded them with a fresh copy. Both of these demos give me the same error. Thank you again for your help

posted by bill vickerman 20 Oct 2016
4 years, 7 months ago.

Hi,

Change your compiler selected platform for DISCO-F746NG and try again.