3 years, 1 month ago.

CLI setup with nRF52 reports Supported targets: 0

I have the nRF52 board. I installed the CLI (command line) and completed all the steps. I tried both on Windows and Mac. When I connect nRF52 on USB, and issue the command mbed detect, here is what I get:

mbed detect

[mbed] Detected LPC2368, port /dev/tty.usbmodemFA131, mounted /Volumes/JLINK [mbed] Supported toolchains for LPC2368 +--+-+-+-+-+-+

Targetmbed OS 2mbed OS 5ARMGCC_ARMIAR

+--+-+-+-+-+-+ +--+---+---+-+-+-+ Supported targets: 0

Did I miss any step? How can I add the target for nRF52?

Comment on this question

1 Answer

10 months, 1 week ago.

Having the exact same problem. The toolchain seems to be installed and according to the toolchain support matrix, ARM_GCC should work with ARCH_BLE but...

> arm-none-eabi-gcc --version
arm-none-eabi-gcc.exe (GNU Tools for Arm Embedded Processors 8-2018-q4-major) 8.2.1 20181213 (release) [gcc-8-branch revision 267074]
...

> mbed toolchain -S
...
| Target                | mbed OS 2 | mbed OS 5 |    ARM    |    uARM   |  GCC_ARM  |    IAR    |
|-----------------------|-----------|-----------|-----------|-----------|-----------|-----------|
| ARCH_BLE              | Supported |     -     | Supported |     -     | Supported |     -     |
...
> mbed detect
...
[mbed] Detected ARCH_BLE, port COM3, mounted D:, interface version 0251:
[mbed] Supported toolchains for ARCH_BLE
| Target | mbed OS 2 | mbed OS 5 | ARM | uARM | GCC_ARM | IAR |
|--------|-----------|-----------|-----|------|---------|-----|
Supported targets: 0

Hmm I tried just compiling for this target and got the error `Could not compile for ARCH_BLE: Target does not support mbed OS 5`, so I guess it is to do with that. Not clear at all though. Also this seems pretty stupid because the NRF51DK apparently *does* support mbed OS 5 and it's the exact same chip.

posted by Tim H 13 Jan 2019

You need to log in to post a question