4 years, 11 months ago.

Blinky doesn't work.

Upon receiving my new LPC4088 QuickStart Board, I plugged it in to a Mac running El Capitan. I compiled the Blinky program successfully. I then downloaded the binary, and dragged and dropped it to the board. The red LED (which I presume is the status LED) blinked while transferring the file to the board, as it is supposed to. But when I pressed the reset button, instead of LED1 blinking, I got solid blues on LED3 and LED4. LED1 is dark.

I tried the same thing a couple of days earlier on a different MBED board (KL25Z) and it worked fine. Actually for that one I had to go to a WIN7 machine to upgrade the firmware. However, after the upgrade that board worked fine running Blinky.

How do I fix the LPC4088? In searching the questions database, somebody suggested unplugging and replugging the USB cable. That did not work for me. After putting the cable back in, I still get LED3 and LED4 lit solid blue and LED1 remains unlit. Thanks!

My firmware is the latest. Here are the two lines from the .htm file that proves this: <! mbed Microcontroller Website and Authentication Shortcut > <! Version: 0203 Build: Nov 24 2014 14:23:24 Git Commit SHA: fa73641e12c39d2595ca566a3d7b19380ece836c Git local mods:No>

HOWEVER, I read that the previous firmware version had trouble with transferring the binary from a mac. Is it then possible that even the latest firmware also has the problem, especially since MAC OS has gone to newer versions since 2014?

Update: I tried the same thing on a dual-boot Ubuntu Linux/Windows 7 machine. On Linux, I encounter the same problem as I did on the Mac. Windows 7, on the other hand, doesn't even see the board at all! So I really need help! Thanks.

Update: Everything works now. On the Mac and on Linux, it was my fault that I forgot to change the platform setting to the new board, and so the compiler produced a binary for the old board. The tutorial I followed didn't say you have to set the setting because it was assumed that the user was new to MBED and so the board setting didn't have to be changed. On Windows, when the board didn't show up as a device, what had to be done was to start the Device Manager. Device Manager then shows the board as an unknown device. You then consent to the system finding a driver for the device, and all was fine after that.

1 Answer

4 years, 11 months ago.

Don't worry I think most of us on here with multiple boards have done the same!

Thanks for your comment! Come to think of it, it should be possible for the compiler to detect what board is connected, and generate the correct binary by default.

posted by Vitit Kantabutra 18 Aug 2016