Report
1 year, 3 months ago.

BLENano fail.txt TIMEOUT

Hello all, I just purchased a BLENano, and I have setup my eclipse to compile the blinky example and that works fine. However, when I plug in MK20 programmer for the BLENano It keeps mounting and dismounting. I can load the bootloader blenano_mk20dx_interface_20140912.bin from here, but when I try to load the nrf51822_blinky_nrf51822_.hex from here as well, the mount doesn't last long enough to complete the transfer.

The filesystem show a file called fail.txt and the contents saying "TIMEOUT". All I am looking to do is to run the hex file from this site https://developer.mbed.org/platforms/RedBearLab-BLE-Nano/.

Any help is appreciated

PS, at times MBED drive shows up TIMEOUTS and the mount permanently disappears until I disconnect and reconnect. It is plugging into a USB3.0 slot. My Device Manager says "This Device cannot start" under the USB controller, USB Mass Storage Device. I am on a windows 8 machine

Question relating to:

BLE Nano is the smallest Bluetooth 4.1 Low Energy (BLE) development board in the market. The core is Nordic nRF51822 (an ARM Cortex-M0 SoC plus BLE capability) running at 16MHz ...

Hello,

What OS do you use ? The interface firmware of the K20F seems a little bit outdated and might have issue with windows 10.

posted by Vincent (pan-) Coubard 15 Aug 2016

Actually, I am using windows 10. I spoke and said windows 8 in my initial questions. Is there a more update MK20 interface firmware? Or are there any workarounds I can do to fix this issue?

posted by Michael Riera 15 Aug 2016

I tried to find an update for the MK20, I didn't find any. I think you can open an issue in the RedBearLab repo for the MK20: https://github.com/Cheong2K/CMSIS-DAP

posted by Vincent (pan-) Coubard 17 Aug 2016

Sounds good I have opened an issue @ https://github.com/mbedmicro/CMSIS-DAP/issues/95

posted by Michael Riera 19 Aug 2016

Did you find a solution to this issue? Initially, I had the same issue. Then I restarted my system and it worked. I got back to using it today and have the same issue. Restarting didn't help.

posted by Uma Arthika Katikapalli 08 Sep 2016

Unfortunately not yet, I am going to inquire the status on the issue.

posted by Michael Riera 17 Sep 2016

:( Yes I have this same issue and yes on Windows 10

posted by Alison Bardo 02 Nov 2016
Comment on this question

4 Answers

12 months ago.

Same issue on Windows 10 with two boards!

Could you tell what is the dongle version?

posted by RedBearLab Hong Kong 22 Mar 2017
8 months, 1 week ago.

Was there a solution to this?

Could you tell what is the dongle version?

posted by RedBearLab Hong Kong 22 Mar 2017
8 months, 4 weeks ago.

This happens to Mac 10.12.3 too.... Any update from the vendor is being required to solve this issue.

Could you tell what is the dongle version?

posted by RedBearLab Hong Kong 22 Mar 2017

It happens on both 1.0 and 1.5 dongle versions.

posted by Taylor Street 07 Apr 2017
7 months, 2 weeks ago.

I tried a couple of different things and I simply couldn't get the BLE Nano to work on Windows 10. I tried using Arduino, copying via the command line.

One thing that I didn't try but just came across: You can download the nRF GO Studio from Nordic Semiconductor's website (www.nordicsemi.com) and try programming it with that. Just plug in the BLE Nano before opening the studio, then select "nRF5xx" in the menu on the left, then select "Write Application" (or something similar to that, I can't remember). If that doesn't work, I don't think anything will.


To post an answer, please log in.