3 years, 3 months ago.

Serial?

I've tried the F030R8 Nucleo_printf program, and it doesn't seem to work on any of my Nucleo F030R8 boards (I've tried 3 of them). The LED is flashing at the slower rate, so the program did download correctly, but I'm not seeing any output on com22 with TeraTerm @ 9600-n-8-1-noflowcontrol.

Did I miss a step somewhere?

Question relating to:

Affordable and flexible platform to ease prototyping using a STM32F030R8T6 microcontroller.
Comment on this question

3 Answers

2 years, 3 months ago.

SB62 and SB63 links worked for me too. Now we are talking :) Thanks Daniel

Hello,

I would like to clarify this point.

Solder bridges SB62 and SB63 are allowing the connection from the mcu pins to the arduino connector (on D0 and D1).

But the connections of PA_2 PA_3 to the ST-link are here even with SB62 and SB63 open. This means that the printf is printing from PA_2/PA_3 through the ST-LINK, via the USB wire to the computer then to the Tera Term.

You can find the schematics of the NUCLEO 64 pins board here http://www.st.com/resource/en/schematic_pack/nucleo_64pins_sch.zip

Are you connecting the tera term serial to the USB COM of the board, or to another serial-wire connector connected to D0/D1 ?

Kind regards

Armelle

posted by Armelle DubocST 10 Aug 2017
3 years ago.

Had the same problem and it turned out that the solder bridges sb62 and sb63 needed to be soldered (the pins marked as PA_2 and PA_3 were not connected to the mcu!!)

3 years, 3 months ago.

Hi Thor, it should work. If it doesn't, make sure you have a recent version of the ST-LINK/V2-1 USB driver (if you are using TeraTerm I guess you are on Windows) and then update the ST-LINK/V2-1 firmware using the latest version of the STM32 ST-LINK utility. The procedure is described in the 'Nucleo ST-LINK/V2 driver installation and firmware upgrade' section in the page for your board: https://developer.mbed.org/platforms/ST-Nucleo-F030R8/

In case you still have issues, also check that you are using the latest version of mbed.

Hope that helps, Antonio


You need to log in to post a question