9 years, 2 months ago.

could not upgrade to mbed

I tried several time the procedure to upgrade FRDM-KL25Z board copying mbed_if_v2.0_frdm-kl25z.s19 to DEBUG drive but when I restart the board I see always FRDM-KL25Z but not MBED

This is my SDA_INFO.HTM file

<head> <title>OpenSDA Hardware</title> <script> function send_data() {document.forms[0].submit();} window.onload = function(){send_data();} </script> </head> <body> <form id="form1" name="form1" method="post" action="http://www.pemicro.com/opensda/index.cfm"> <input name="tag" type="hidden" id="tag" value="description" /> <input name="BOARD" type="hidden" id="BOARD" value="FRDM-KL25Z" /> <input name="BOOTVER" type="hidden" id="BOOTVER" value="1.01" /> <input name="APPVER" type="hidden" id="APPVER" value="1.01" /> <input name="DUID" type="hidden" id="DUID" value="74823937-473181BE-377CF805-B66DE678" /> <input name="EUID" type="hidden" id="EUID" value="6AE3D036-A84B8750-187BDA22-947668D6" /> <input name="TUID" type="hidden" id="TUID" value="74823938-4732819A-3796E804-A46CDC77" /> <!471> <input name="TOA" type="hidden" id="TOA" value="86B6E505-593C7F2A-637FDE17-009F1216" /> <input name="TOA2" type="hidden" id="TOA2" value="86B6E505-7D4A3E2B-16D2E1CF-364A9871" /> <input name="SUID" type="hidden" id="SUID" value="86B6E505-6C47961D-37239804-8003EC65" /> <input name="MICROVER" type="hidden" id="MICROVER" value="1.01" /> <input name="APPNAME" type="hidden" id="APPNAME" value="PEMicro Mass Storage App" /> </form></body></html>

Can You help ?

Best regards Fabio

Question relating to:

4 Answers

9 years, 2 months ago.

Hi Fabio, are you holding down the reset button when you plug the board in? It should appear in explorer as 'BOOTLOADER' when you do this, rather than 'DEBUG'.

9 years, 2 months ago.

The problem was that the copy of the file should be made in command line mode (dos)

best regards Fabio

9 years ago.

See my answer here: http://mbed.org/questions/744/I-cant-upgrade-to-mbed/

You need to hold down the RESET button when plugging in the board to get the BOOTLOADER drive.

8 years, 10 months ago.

the upgrade process doesn't seem to work, if you use Teracopy. uninstalling it solved the issue on my pc