3 years, 3 months ago.

Problem with initializing LCD display

Two years ago I bought an 5110 display: http://www.dx.com/p/replacement-1-6-lcd-screen-with-blue-backlight-for-nokia-5110-blue-145860#.V4im-riLSM8 I tried it for the first time yesterday. As you can see the pins are not ordered the same way on this device as the one sold by adafruit for example. Anyway the pins are clearly labeled, so that is not a problem.

I have successfully tried the LCD with an STM32F429I-Discovery board. The LCD nicely prints stuff. With the STM32 board I tried this example: http://stm32f4-discovery.net/pcd8544-nokia-33105110-lcd-stm32f429-discovery-library/ Worked fine!

I then moved to mbed to use my FRDM-K64F board. But when using the suggested 5110 library (https://developer.mbed.org/users/eencae/code/N5110/) I run into problems when running: N5110::init() I am unable to send SPI commands to the display. Basically after first sendCommand() call the CPU is waiting for transfer to complete, i.e. it hangs here: /* Wait till TCF sets */ while (!(DSPI_GetStatusFlags(base) & kDSPI_TxCompleteFlag)) { }

Anyone have had similar issues with this display and library?

Question relating to:

Comment on this question

1 Answer

2 years, 10 months ago.

this mbed is a piece of shit..... i have set stm board and it says

Error: Identifier "p8" is undefined in "main.cpp", Line: 18, Col: 20

this is LPC pin names


You need to log in to post a question