4 years, 6 months ago.

ST Nucleo F401RE RTC fix

I have an ST Nucleo F401RE rev. C-02 board (with X2) and tried to use the RTC with a CR2032 external battery and desoldering SB45. I found that the RTC was cleared after a power cycle or reset, so practically was useless.

Fortunately I discovered that Kenji Arai had solved this issue patching the file: /mbed-src/targets/hal/TARGET_STM/TARGET_STM32F4/rtc_api.c

Link is: http://developer.mbed.org/users/kenjiArai/notebook/nucleo-series-rtc-control-under-power-onoff-and-re/

I tried this patch and now RTC works as it should. My question is: This patch will be implemented in official mbed ? Normally RTC should "just work" without the need to include mbed-src in a project and patching it.

Many thanks to Kenji Arai for his excellent job on this issue and to the ST and mbed teams. I have started working with Nucleo and mbed and really like them!

Comment on this question

1 Answer

4 years, 6 months ago.

It will/might be implemented in the official mbed if someone makes a pull request for it on github: https://github.com/mbedmicro/mbed. But then someone needs to do it, would of course be best if Kenji Arai would do it.

I found my name in the question and answer. I'm not familiar for GitHub but I will try it.

Alex, thanks your comment and it's my pleasure.

posted by Kenji Arai 03 Mar 2015