5 years, 7 months ago.

printf and viewing commands in the mac terminal

Sorry if this has been covered, I have looked through forums but not found a solution that works for me.

I want to view the printf text that the mbed creates on my computer. It's a mac, running 10.9.5. I'm not great with the terminal, but I can do basic tasks.

I've tried ls /dev/tty.* and found that my mbed is on: /dev/tty.usbmodem1412 (verified by unplugging mbed)

I then try the command /dev/tty.usbmodem1412 which as I understand should let me access the mbed in the temrinal.

I get:

-bash: /dev/tty.usbmodem1412: Permission denied

Googling this comes up with results for ubuntu users saying, make your user a member of dialout. However this group doesn't appear to exist on mac.

attempting:

sudo dseditgroup -o edit -a myusername -t user dialout

has the response:

Group not found.

Can anybody help please?

2 Answers

5 years, 7 months ago.

You forgot the 'screen' command. Try 'screen /dev/tty.usbmodem1412' after the prompt.

example: bash-3.2$ screen /dev/tty.usbmodem1412

Accepted Answer

Doh! Thank you. That's fixed it for me. So Permission denied was the OS' way of saying 'I don't understand?'How daft.

Thank you very much for your help

posted by Rowan Diskin 11 Feb 2015
5 years, 7 months ago.

Try CoolTerm. It's a very nice, easy to use serial terminal program.

I'm using it with mbed LPC1768 and Arch Pro on OS X 10.8.5.

Thanks, I'll try it.

posted by Rowan Diskin 11 Feb 2015