3 years, 10 months ago.

Is LPC4088 QSB compatibile with Windows 10?

I have developed with the LPC4088 QSB for several months on a Windows 7 PC. I just got a new Windows 10 computer and have immediately run into the problem that I cannot drag-and-drop programs to the QSB USB drive. The Windows copy status bar shows 0% progress for a while, then the drive disconnects, then the drive reconnects showing a file "failed.txt" containing the single word TIMEOUT. The program is not transferred to the QSB.

Several others have had this issue with other MBED platforms (just search "Windows 10" on developer.mbed.org). Do you have any idea of a Windows 10 configuration change, QSB firmware update, or other workaround to address this problem? Thanks.

Question relating to:

The mbed-enabled LPC4088 QuickStart Board from Embedded Artists is a easy to use ARM Cortex-M4 rapid prototyping board in a standard through hole DIP package (44-pin), targeted at high-performance as ...

I have further determined that just attaching the QSB to the USB port under Windows 10 wipes out any existing program load. The QSB won't run again even after disconnecting. I have to reload the program by connecting the QSB to a Windows 7 machine and doing the drag-and-drop from there.

posted by Thom Bronez 17 Dec 2015

Investigating further I found the new PC has a 3rd party antivirus program that interferes with the QSB USB drive. I solved the problem by disabling removable media scanning in that program.

posted by Thom Bronez 23 Dec 2015

I have the same problem with Windows 10 and LPC4088. It is not a problem of an antivirus program (it does not work without the virus program LPC1768 works fine under Windows 10

posted by Rainer Knust 05 Jan 2016

I have Win 10 installed on all PCs I have access to. I have at least seven LPC4088 boards that now show SWD Errors. I just bought five extra LPC4088 boards and the first time I tried one I got a fail.txt showing "BAD EXTENSION FILE".

I have re-loaded the most recent version of the firmware on all these boards. I have powered them while holding the user button. I have removed my anti-virus. I have tried connecting them to a Win7 machine. I have searched the forums and tried every posted solution and have yet to recover a single board once I start getting these errors. This thread was my best hope, and it has proved to be of no help.

I am *very* disheartened by the lack of a definitive solution to this problem, even though I see people posting about it on several different mbed processors going back a couple years. The lack of response from mbed developers makes me wonder why I tried using these processors.

I have a dozen pieces of equipment out in the field running with LPC4088 boards. If I can not resolve this issue I will have to discontinue using these processors in any new designs.

posted by Paul Kidwell 02 Mar 2016

I have the same problem with Windows 10. I didn't have it when I programmed the board with Windows 7. Is there a something wrong in the driver with Windows 10 ?

posted by Jeremy Guillonneau 11 May 2016
Comment on this question

5 Answers

3 years, 2 months ago.

I've a similar issue on my win10 64bit laptop, I plug in the device and can see it enumerating in the task bar. But then when I go to "My Computer" there is no mBed device visible, I've restarted the machine and get the same results.

I plug the same device into my win7 64bit desktop and the device functions properly. Allowing drag and drop programming etc.

The only antivirus on teh laptop is windows defender, but looking at it's logs I cannot see it blocking the flash driver.

I've refused the free upgrade to win10 on my desktop to allow me to keep working at the office but sometimes I need to work remotely and the laptop is required for this.

3 years, 9 months ago.

Wow. It works. It took me many hours until reading this post, and removed my antivirus. Thanks so much.

3 years, 9 months ago.

removing the antivirus program did not help. LPC4088 do not work with and without antivirus. The LPC1768 platfrorm work very good under windows 10 (also with a 3rd party antivirus program).

I'm using Windows 10, and I ported my old code from LPC1768 which worked with Avira antivirus. I removed Avira and installed Avast. I still don't see the file in the MBED drive after burning the code, but the code ran. Try to burn a simple blinking LED code.

posted by Visarute Pinrod 05 Jan 2016
3 years, 1 month ago.

We see the same problem, 2 different boards. Just plug them into a windows 10 machine and any program on them is wiped. You end up with two faint blue led3 and led 4.

Trying to load a program gives a fail.txt with SWD Error or timeout or BAD EXTENSION FILE.

It does sound plausible that something on windows 10 is trying to scan the inserted flash drive but this computer has no anti virus and I temporarily turned of windows defender with no luck.

Sometimes a small program like Blinky will work but not reliably.

(Everything works fine from a Mackbook Pro)

3 years, 1 month ago.

The firmware has been updated to work on Windows 10. The update instructions and the binaries can be found here.


You need to log in to post a question