3 years, 11 months ago.

NUCLEO-L476RG example codes are not working

I compiled and downloaded the Nucleo_blink_led and the Nucleo_printf example programs to my NUCLEO-L476RG board. I installed the necessary ST-LINK/V2 driver and upgraded the firmware of the device. When I download the compiled program (.bin) to the board the LED on the programmer starts blinking (switching between red and green light), then turns to green light.

After this nothing happens, I tried to reset the board, power off and on again, but it's not doing anything. In the case of the 'Nucleo_blink_led' example the user LED is not blinking, in the case of 'Nucleo_printf' I don't receive anything in the device's Virtual COM port. I also tried to export the projects from the online IDE into Keil but I got an error message (I tried with Firefox and Chrome): "Unable to export for this target. Please contact support".

I don't know what else should I check/try to resolve this issue, I would appreciate your help!

Comment on this question
Be the first to answer this question.

You need to log in to post a question