4 years, 2 months ago.  This question has been closed. Reason: Off Topic

how to run embed libraries for stm32 nucleo on kiel

hi, I am trying to run the libraries on kiel, I have used the export option, may be I am not able to setup my kiel environment properly, can anyone tell me the step by step procedure for it.

I am using STM32 Nucleo F401RE

1 Answer

4 years, 2 months ago.

I use the STM32L1 Nucleo board, exporting to Keil µVision 5 works, the import gives just a warning that the project gets upgraded from µVision 4 to 5, after this coding and debugging within µVision works fine for me.

Sometimes when I am in deepsleep the Nucleo may not get detected, in this case I hold the reset button, click debug in µVision and release the reset button, than us usually flashes the program and start debugging.

First I would recommend to verify that the STM ST-Link drivers and utilities are installed and running. Next step is the Keil environment.

To a large extent the problem is solved but I am still not able to download program on the board, I have downloaded device drivers properly as it was running properly for mbed online compiler.

the error displayed by compiler is Error: Flash Download failed - "Cortex-M4"

posted by akshay ingle 15 Sep 2015