Report
3 years, 5 months ago.

Windows 10 - USB mount doesn't work correct anymore - u-blox C027 board

Hello,

I got the update from Windows 8.1 to 10 and since the OS update the USB mount doesn't work correct anymore.

In general the board is mounted but moving binaries to the board doesn't work anymore and it looks like that the board is remounted on a regular basis (about once per minute).

Using the same board (u-blox C027) on a different system everything works as usual. Therefore I assume some specific configuration for Windows 10 is required.

Does someone have any idea what needs to be configured in Windows?

Thanks in advance, Martin

USB is very important for in today's date . Actually it was great for everyone and also helpful and also it was great. And also we got very great feddback from users. And in window's 10 I also faced this problem if you want to know the proper solution then follow the site . From the site you know everything about it. So follow the site. https://printerssupport.org/xerox-printer-support/

posted by google support 12 Jun 2018
Comment on this question

6 Answers

3 years, 2 months ago.

I had a similar problem with a new Windows 10 PC. I discovered the 3rd party antivirus program that came with the PC was the culprit. I solved the problem by disabling removable media scanning in that program. Perhaps your upgrade modified settings of your existing antivirus software.

3 years, 1 month ago.

Same problem here. I plug any of my c027 boards into Win 7 machine and download blinky, no problem. I unplug from Win 7 and plug into Win 10 (while blinky is running), board enumerates, blinky is gone (I see some USB activity indicated on the c027 LEDs upon enumeration), then the unit de-/re- enumerates about every 15 seconds. Trying to program board on Win 10 does not work. Moving the board back to Win 7, blinky is still gone, but I can now reprogram board and all is good again.

My guess is that upon enumeration in Win10, something is copying a file to the c027 mBed FS which blows away the program (blinky in this case). Why it is doing the enumeration dance, I haven't a clue. I've disabled antivirus and rebooted and nothing fixes it so far.

1 year, 9 months ago.

This page fixed the problem on my board which , though it was bought a week ago had the old firmware (CMSIS DAP Firmware 2.00 (22 Oct 2013) installed.

Reflashing with CMSIS DAP Firmware 2.01 (23 Apr 2014) fixed the problem

https://developer.mbed.org/users/ublox/notebook/ublox-C027-Update-CMSIS-DAP-Interface-Firmware/?c=27351

4 months, 1 week ago.

I did also get the update from Windows 8.1 to 10 but the window is not activated so what can I do in this condition and Another question on my mind about the security purpose of my friend suggest me about the 360 total security software and it try it in free for first 30 days I think its good for beginners for more information about it http://360totalsecurity.antivirushelplineaustralia.com/

3 years, 4 months ago.

Having the same exact issue with my Freescale KL25Z and K22F boards. If anybody knows something, please share.

Hi,

It looks like that this issues is as well know as "disconnect and reconnect" issue and appeared on previous MS OSs as well.

https://support.microsoft.com/en-us/kb/2416007

" Cause

This occurs because of a race condition in the USB driver when the operating system concurrently processes a request to resume from selective suspend and a request to disable wake on device connect. When the issue occurs, an unexpected USB bus reset is sent to the USB device driver. This causes the device to be removed and therefore a new device arrival notification and reinitialization occurs for the device. During this time, the USB device may disappear and reappear. "

In my case a reboot of the PC solved the issue and I have not experienced this issue any more until now...

posted by Martin Pamler 29 Sep 2015

Reboot doesn't help as I've been having this problem for months. Ever since I upgraded to Windows 10 actually.

posted by Sławomir Błauciak 29 Sep 2015
3 years, 4 months ago.

Have you checked to see if there is newer firmware? I had an issue maybe 6 months ago with a KL25Z on Win10, and after some digging found that there had been some firmware updates around the end of 2014 that resolved the issue.

I'm using the latest available firmware. I complied it myself

posted by Sławomir Błauciak 06 Oct 2015

To post an answer, please log in.