5 years, 9 months ago.

nRF51-DK: exported gcc version didn't work

I tested mbed_blinky in developer site. This version is working good.

But same project export gcc version. I compiled this project in my computer. gcc version didn't work.

Let's me know What's wrong form me?

PS mbed_blinky_gcc_arm_nrf51_dk.zip file is export file. /media/uploads/jade74/mbed_blinky_gcc_arm_nrf51_dk.zip

Best Regards. Jade, Lee

Question relating to:

The nRF51 Development Kit is a single-board development kit for Bluetooth Smart, ANT and 2.4GHz proprietary applications using the nRF51 Series SoC. This kit supports both development for both nRF51822 …

Can you provide more details ? share the errors? how does it not work? compilation errors? runtime errors?

posted by Martin Kojtal 27 Jan 2015

mbed_blink example is just blink led. I imported sample from mbed site.

compile & linking is done without any problems.

But running the code(copy to Storage), After reboot led is not blinking.

I attached test program /media/uploads/jade74/mbed_blinky_gcc_arm_nrf51_dk.zip

It is same KEIL uVision Project. I do not know what the difference is "Local build" vs "Web Compiler Build"

posted by Jade Lee 27 Jan 2015

2 Answers

5 years, 7 months ago.

I'm having this issue, even after running make merge. Everything compiles and links without errors, but after drag'n drop the "combined.hex" file, nothing happens. It seems it's not jumping to main(), since I have LED1=1 at the beginning.

Anyone has an idea of what can I do to solve this?

5 years, 8 months ago.

Hi all guys, I'm experiencing the same problem written above.

I've successfully ran the online-compiled version of the blinky test code. I've tweaked it a bit so it is 244836 byte large. I copy it on the FileSystem and it runs as expected.

I've also tried exporting this example for offline working (that is what will be my stable workbench) and it compiles and link nicely.

The first strange thing is that the .bin (which is said to be the right version to flash in the last line of this document https://developer.mbed.org/handbook/Exporting-to-GCC-ARM-Embedded ) executable is only 29988 byte large while the .hex is 84402 byte large.

As I drag'n drop the .bin file onto the drive, it appears a fail.txt reporting "OUT OF MEMORY".

If, otherwise, I drag-n drop the offline-compiled .hex file, it appears the same file reporting "CORRUPT FILE".

Can you please where I'm doing wrong? Have you any hint for a newbye like me? Thank you in advance.

Have a nice Sunday :)

online IDE using ARMCC to compile, while you are using GCC ARM. means different cmsis files (linker file, startup) , plus different toolchain. Does it jump to main() ?

posted by Martin Kojtal 08 Feb 2015

Hey guys! I'm glad of informing you that I've solved the problem! Here is the solution to my issue: reading the Makefile I've noticed that it expose a nice "merge" target. Now, I was aware that this particular MCU has a precompiled part used by bluetooth (the so called SoftDevice) and I wondered if its absence would have cause a malfunctioning. So I worked it a bit (it was not up to date according to the directory tree of the project) and, after the classic "make", I ran "make merge". This creates a new file that, moved into the mbed FileSystem, works as expected :)

Thank you anyway for the support!

ps: If you know a way to correct the Makefile in the online repository so anyone would download an up to date version, let me know !

posted by Francesco Franchina 08 Feb 2015