5 years, 3 months ago.

Where does the export go?

I try to export to IAR and to zip files, but there is no indication of where the files are going, and I cannot find any output on my PC.

Question relating to:

10 Answers

5 years, 3 months ago.

Thanks for pointing out that the export service is down. We'll get this restored shortly.

FYI - It does seem that exporting from a program page works, just not from the IDE.

Accepted Answer

It is really hard to understand for me that in situation of such FATAL BUG BLOCKING WORK for many peaple the 'mbed team' reacts after 3 days !!! (First annoucement was here https://developer.mbed.org/forum/mbed/topic/16887/?page=1#comment-39369)

How it is possible, that doesn't exit some HOTLINE for such cases ?!

It's true that the mbed is free BUT ARM is selling hundreds of licences to chip vendors for each Cortex type so IT IS REAL BUSSINES and it should be normal to supply free or cheap tool(s) for development as the users are BUYING the controller chips. I agree with trahn knee completely that the development with mbed is very poorly documented and the work with it is often frustrating - including the situation with non-functional and non-available officially associated mbed HW platform (e.g. GR-PEACH, DISCO-F746NG and others - see https://developer.mbed.org/questions/54296/How-to-add-this-platform-to-MBED-compile/) !!!

There will be such horribly amateurish situation also with paid 'mbed Device Server' ?!

posted by Ales Burian 16 Aug 2015

Sam,

Thanks for the reply.

To clarify things a bit, I was not complaining about embed per se, but rather the entire ARM ecosystem. I am very frustrated. I have to date, tested five different IDE/Compiler environments, including one which sports a $5000 euro price tag. They are all fairly stinky in my opinion and most vendor's tools lock-one-in to that specific tool-set. On the other hand, while all the abstraction is supposedly useful for rapid port-ability, without adequate documentation that (in theory) enables new users the ability to seemlessly integrate different targets & platforms by employing higher layer abstracted code-modules. What good does it afford if one does not know how to use software target ecosystem? Since I have made the transition from AVR/PIC/TI/etc 8/16 uControllers, all I have done is read. Coding has come to a stand-still. I've been coding uControllers, mini-computers and super-computers for over thirty years and this ARM has stopped me cold. Why? Bad technical information. Plain and simple. And its not just one vender specific either, I find this state of affairs extant everywhere. But I pinch myself for a reality-check...other folks are successfully programming these little beasts? So what is it that I am missing?

Ad rem....regarding the exporting anomaly... I need to export my project, not just mbed's code examples, which are also, very useful. Thanks. However, in any case, I need the IDE export function. But thanks for edifying us.

trahn knee, just another bench swarfer

posted by trahn knee 16 Aug 2015

@Thran, while you won't get a discussion from me that mbed has huge issues, what information are you missing that prevents you from coding? To me most stuff seems pretty similar to for example an Atmega MCU. Sure some stuff is different, but most information for the different stuff is not used all that much, and if it is needed google manages to give it to me fairly quick.

posted by Erik - 16 Aug 2015
5 years, 3 months ago.

I think there is a bug on the website right now, i tested last Tuesday and it worked fine !

5 years, 3 months ago.

I found this too, I could have sworn around December that you could do exports. I have tried this yesterday and today, trying all compiler outputs and nothing seems to be happening. The IDE says "Downloading file..." and then absolutely nothing happens.

5 years, 3 months ago.

Same here! Tried with internet explorer and firefox.... two ore three days ago it worked fine

5 years, 3 months ago.

Likewise: I click the 'Export' button, and nothing happens!

5 years, 3 months ago.

This bug has been caused by the 'Scheduled Maintenance Thursday 6th August' There was some discussion in other Forum item about returning some changes back last weekend resulting the 'Export Program..' option has been working again... BUT this bug has returned back around 3 days ago !!

Can you give a link to that "other Forum item" ?

Was there any workaround?

I found a forum discussion about this: https://developer.mbed.org/forum/mbed/topic/16887/?page=1#comment-39369

But no mention of maintenance

posted by Andrew Neil 15 Aug 2015
5 years, 3 months ago.

I'm encountering this issue too, also my program behavior is very strange, it works fine but when I compile it again, is suddenly stops working! It's very annoying :-(.

I choose "Update All" from right click menu on my project, and all of my project files are gone!!! I don't know what to say...

Loosing files that way should certainly not happen. Did you use the local version control functions to restore a recent version of your code? In case you cant recover using version control send a message to support@mbed.org. The mbed staff may be able to help you using the system snapshot files.

posted by Wim Huiskamp 16 Aug 2015
5 years, 3 months ago.

Hello All,

A disillusioned ARM newbie here who is beginning to think that my decision to move to ARM development may have been a big mistake and not worth all the pain of enduring the disjointed bad documentation, bad tools, and all the other BS hassle that I'm finding everywhere in the 'ARM ecosystem'...really stinky.

However, ya'll can add another name to this growing list of broken embed compiler/export functionality, as Yesterday (08-13-2015), and last night (08-14-2015) and now today the embed compiler is behaving very differently than it did on Thursday (08-13-2015) which seemed to function...adequately. I was beginning to think that maybe I found something that might actually work as advertised and for a price that I can actually afford, myself being a retired engineer/hobbyist. Couple that with the fact that I am struggling to understand how to compile and cause to work all of the badly documented (DoxyBlock 'comment' crap being foisted on us...shoved out as 'documentation') and source files. Its a veritable nightmare!! Unless one happens to have $5,000 euros to spend on some ARM vendor tool, the only other tools available are crap, a condition that seems to be prevelent everywhere in the freebie or almost free ARM ecosystem. ARM is a truly kewl processor, but the ecosystem for the most is shit. And now mbed is screwing up with no mention by the owners of it. How kewl is that?

So embed, when can we expect to see and to be able to use your online ecosystem so we can begin working again?

Here is a classic and another very good reason, via a practical illustrative example of why one must not be reliant on central 'broadcast programs' such as mbed. It is a very kewl idea, but if it goes down, everyone who uses it is fucked.

swarfer

5 years, 3 months ago.

What is currently the working way to export a program? (Or when will there be a working solution)

Going to https://developer.mbed.org/compiler/ and trying to export a program in the 'Workspace Management' (the main window) does not work for me in chrome. (And neither did it using the 'Program Workspace')

for both tries, I used the 'right mouse button menu'

Thanks,

Without trying it, I think you can publish it, and them from the webpage of the published program export it.

posted by Erik - 16 Aug 2015
5 years, 3 months ago.

hi,

interesting ;-) the statement is made that the export function works. using firefox and chrome doesn't seem to work. at least no output has been generated.

before my holidays it did work ...

thanks

"Without trying it, I think you can publish it, and them from the webpage of the published program export it."

yes, that works. but it pops up another build problem. the binary fails to run :-/

on the mbed device a fail.txt will be created. the content is simple: CORRUPT FILE

the offline build process seems to be very buggy.

posted by robert bouwens 17 Aug 2015

ok, the exported programs are completely broken. when using the online compiler it resulting binary works. using the binary produced by the offline compilation fails.

posted by robert bouwens 19 Aug 2015