9 years, 5 months ago.

Problem with nucleo STM32F411

Hello

I am try this demo with my nucleo 411 with arduino eth shield (W5100)

using terminal i see output

Starting Ethernet Server ... Initialized, MAC= 00:00:00:00:00:00 Connected.. Communication Failure ... Restart devices ... Waiting for connection to ThingSpeak server...Connection attempt to ThingSpeak server failedWaiting for connection to ThingSpeak server...Connection attempt to ThingSpeak server failedWaiting for connection to ThingSpeak server...Connect

In my network i can't see this board (i can't ping)

Any idea ? :)

Best Regards Robert

Question relating to:

Local version for working on Nucleo F401 and Ethernet shield

2 Answers

9 years, 5 months ago.

Hello Robert,

It looks to me like the communication to the etherned shield is not working since the mac address is coming back as all zeroes. Have you checked the SPI connections? They need to be made to the special six pin connector on the board. Also the chip selects for the ethernet board and the SD card need to be set correctly. I don't know if there are major differences on the F411 boards maybe there is another conflict there besides the LED.

Actually this version of the program has some changes I made later to work with another api. It's probably not the best demo at the moment for the board. But should at least be able to ping the board on your local network.

Kind regards

Ian

8 years, 9 months ago.

Hi Robert,

I am having a similar problem, I get a mac address, but then after about 8+ seconds I end up with the message Comms failure, the one from pc.printf("IP=%s\n\rMASK=%s\n\rGW=%s\n\r",eth.getIPAddress(), eth.getNetworkMask(), eth.getGateway());

Any ideas?

Hi Glendon,

I tried this code again and it is still working on my F401 with the Arduino Ethernet Shield.

If you see the correct MAC address from the board then the communication to the shield is working but the call to eth.connect is failing. Which means the shield can't set up the network connection.

The example here is based on the shield obtaining an IP address my local network using DHCP. Can you check the following:- Is your local network set to give out addresses? Are the gateway and mask set correctly for your network in the code?

If you just want to get the hardware working the example Teams/Shields/code/Seeed_Ethernet_Shield might be worth a try. I believe this is similar or even the same hardware as the Arduino shield.

Hope this helps

Ian

Updated 23 Sept. 2015

Hi Glendon,

I think I can confirm your observation about the temperature being hotter without the cable. If you can rule out the network configuration then I have only two suggestions:-

Can you check the markings on the Wiznet IC to see what version it is and get the documentation from the Wiznet site? Maybe there are some differences that the library needs to be configured for.

In the library there are some printf's for debugging. How about trying to reactivate those to see exactly what is failing?

Sorry I don't have anything better at the moment. Good luck with your board.

Ian

posted by Ian Kilburn 22 Sep 2015

Hi Ian, I am not sure why this doesn't work. I purchased a cheap ethernet/SD shield from EBay, and have the SD card working. I can see the CS going high then low again on my DSO, I can also see the clock. I am using the F411 variant. I don't have the shield plugged directly into the Nucleo board, it is connected with short jumpers. My home network has a DHCP server and a static range for some of my internal gear (NAS, Web server (php, mysql), NVR etc. I generally know what I am doing with networking (It's part of my job).

I have now tried at least three different libs without success. Can you advise how warm the W5100 chip gets? Mine seems to be a little warm (say approx 35c) with the ethernet cable connected, but gets a fair bit warmer without the cable (maybe up to 50c). Do you have a similar condition?

Many thanks for your reply, it's greatly appreciated.

posted by Glendon Turner 23 Sep 2015