7 years, 8 months ago.

I'm having problems switching between Windows and Linux based systems.

I programmed my mbed using Windows and the mbed worked successfully. Then I tried to use it on a Linux based system with some results. Then when switching back to Windows the computer would not recognise the mbed and suggested i format the disk.

Is there a fix for this problem?

EDIT: I tried the things on the deadmbed page with no luck.

When I plug in the mbed in the Windows machine the it sees the removable drive but a prompt comes up asking me to format the drive. Accessing it is not possible (it just says please insert a disk into removable drive) and formatting fails halfway through. Files cannot be copied over to the mbed. When I'm trying to access the mbed the blue light flashes.

Any ideas?

1 Answer

7 years, 8 months ago.

While I wouldn't consider your mbed "dead", you may well find some useful tips on the cookbook page deadmbed.

Trying a different USB cable is definitely worth a shot. If you're stilling having problems please edit your question with the results of the tests on the deadmbed page.