5 years, 8 months ago.

Build Error?

Cannot run program "": Launching failed

Error: Program "" not found in PATH

Question relating to:

2 Answers

5 years, 7 months ago.

I had this problem too. The issue is that you've selected the wrong toolchain.

Right click the project in Eclipse and go to Properties. Go to C/C++ Build > Tool Chain Editor. Change your "Current toolchain" from "Cross ARM GCC" to "Cross GCC". That should fix the problem.

If you then get an error that make wasn't found, you need to add the gcc4mbed directory to your PATH. Add "C:\gcc4mbed\external\win32" to your PATH (adjusting for wherever your gcc4mbed directory is.

5 years, 5 months ago.

I've had this problem as well - unsurprisingly things move on and details change...

Using Eclipse Luna (it's now onto Moon but I haven't tried that yet) & adamgreen-gcc4mbed-3b4f8cb.zip I had two problems: 1. the supported tool chains have changed and no longer contains "Sourcery G++ Lite". The most plausible one listed is "Cross ARM GCC" 2. "Properties | C/C++ Build | Builder Settings | Build command:" references ${cs-make} which seems to be undefined. This is what causes your problem of

Error: Program "" not found in PATH

Change the Build command: value to

make

and then the makefile will run and you can clean and build the mbed binary for your selected targets.

Needless to say, setting up Eclipse is fiddly and I had to work through the instructions twice to get it right. I found the section "Additional notes for Windows users" helpful although the \ / issue no longer seems to be a problem.

Finally, to get the full benefit of Eclipse you need to work through the "Eliminate Indexer Errors" section. I found that adding the line

GCFLAGS := -v

to the project's makefile useful as it lists all the include file paths. This helps you find directories (you won't need them all) to remove problems and errors from Eclipse's view of the code.

Good luck