5 years, 11 months ago.

Can't get BLE_iBeacon Manufacturer Specific Data

I have a nucleo L152RE with the BLE shield on it.

I am running the project here:

https://developer.mbed.org/teams/Bluetooth-Low-Energy/code/BLE_iBeacon/

It builds and runs fine. The problem is that none of the manufacturer specific data is coming through.

I am also writing my own iOS application and when I debug into the didDiscoverPeripheral method of my iOS application the advertising array of data does not contain the manufacturer specific data packet in it.

I also tried using the heart rate monitor example. It works fine as the HRM, but when I try to add manufacturer specific data to it I never see that.

I also have an RFduino device and my iOS application CAN see the manufacturer specific data that it sends in its advertising packets, so I know my iOS application is written correctly.

Can someone please help me figure out why I can't get the mbed nucleo with BLE shield to send manufacturer specific data?

I have done some more testing and still can't get this to work. I tried a the BLE_GAP_Example with the same results. I can see the device and the custom name that I change it to, but any manufacturer specific data that I add (which this second example is all about) never comes through.

posted by Tony Pitman 22 May 2015
Be the first to answer this question.