6 years, 3 months ago.

K64F Ethernet Library working?

Hi

I have a problem with the Ethernet Interface on the K64F. I tried to compile different programs but all with the same error:

Error: Too few arguments in invocation of macro "BW_MPU_CESR_VLD" in "EthernetInterface/lwip-eth/arch/TARGET_K64F/hardware_init_MK64F12.c", Line: 44, Col: 22

Error: Expected an expression in "EthernetInterface/lwip-eth/arch/TARGET_K64F/hardware_init_MK64F12.c", Line: 44, Col: 5

I was able to compile all programs a few month ago, now nothing is working. Does anybody has an idea?

Thank you very much gulchi

what mbed lib revision? any ethernet program will fail?

we need some details to reproduce this and possibly fix ;)

posted by Martin Kojtal 02 Nov 2014

Current revisions of mbed and EthernetInterface. Working when you switch mbed back to revision 89.

posted by Ales Povalac 03 Nov 2014

2 Answers

6 years, 3 months ago.

Hello,

is this still relevant ? there was another similar issue, and I am quite confused as checking latest mbed SDK sources, it should be fixed. Please share your revisions, so I can go to log , check files and then import them to see if it compiles. THanks

Regards, 0xc0170

6 years, 3 months ago.

Yes, still broken for me. Please check http://developer.mbed.org/users/alpov/code/MPOA_cv5_updated/ . If you update mbed to old rev89, it works.

You also need to update lwip, lwip-eth and lwip-sys inside the EthernetInterface folder then it should work.

posted by Kevin L. 14 Nov 2014

Thanks! I didn't realize that the included libraries are not updated with its parent... some "update all" action will solve this. Now I need to change my MAC adresses, because new mbed overrides weak mbed_mac_address() with its own strong function... but that's another problem.

posted by Ales Povalac 14 Nov 2014