5 years, 11 months ago.

Nucleo with CC3000

I have problem with the cc3000_hello_world_demo. I'm using a STM32F302R8 Nucleo with a Adafruit CC3000 shield on the Arduino header.

It was able to connect and get an IP the first few times, but now it always hangs in wifi.init().

It's stuck at:

include the mbed library with this snippet

main ->
    cc3000::init()
    cc3000_wlan::start
    simpleLink_init_start
    _hci.command_send(HCI_CMND_SIMPLE_LINK_START, ptr, WLAN_SL_INIT_START_PARAMS_LEN);
    cc3000_spi::write
    cc3000_spi::first_write
    write_synchronous
    SPI::write

I haven't figured out how to rebuild the mbed lib to see where in SPI::write, but it either waiting to write or read the response.

I tried using an external 5v power supply connected to the E5V/GND on the Nucleo, setting the jumper to E5V, and following the power on sequence, but it still hangs at the same place. I think the Nucleo can power the shield like this.

The pin connections between the shield and Nucleo seem ok.

I've also tried lowering the SPI frequency, but that doesn't help either.

Any ideas?

Question relating to:

have you tried to connect with no security? Do you have any other board to test? Strange it worked the first few times. You can also export the program, using mbed-src and set optimization to 0, to test if that solves anything.

posted by Martin Kojtal 23 Oct 2014

It works now with mbed-src rev 364.

My original project with mbed rev 89 (equivalent to mbed-src rev 322) converted to a library (my only changes are for debug print) still has the SPI problem. A clean project with mbed rev 89 can pass wifi.init(), but can't connect. I think everything else is the same.

I'll keep using mbed-src for now.

Thanks

posted by Lawrence Mok 23 Oct 2014

Did you solve the issue??

posted by Cristian Fuentes 06 May 2016
Be the first to answer this question.