5 years, 1 month ago.

Has anyone tried using web sockets with seeed gprs shield ( sim900 module ) ?

hello, when i tried to use seeed gprs lib in place of ethernet lib in websocket_ethernet_helloworld example provide on mbed, the connection was successfully established. however the program still couldn't open web-socket. On enabling the debug I found the connection was dropped by line #146 of Websocket.cpp . Any idea what would have caused it ?

Question relating to:

Comment on this question

4 Answers

3 years, 4 months ago.

"It opens a TCP socket but it writes empty buffer" - Anyone got a solution to this?

4 years, 6 months ago.

I realize this is a somewhat old issue, but it's worth mentioning this part has been discontinued. So unfortunately we can't troubleshoot the problem with this module. I've updated the component page with this info here: http://developer.mbed.org/components/Seeed-GPRS-Shield-V20/

If there's anything else you feel should be added to the component page, let me know.

Thanks,

Brian

4 years, 6 months ago.

You may get help using the seeed forum. Or even looking at Linkit-one while you are there, i know it moves away from mbed, but if you are happy with the Arduino IDE it could be for you.

4 years, 8 months ago.

I'm having a similar problem when I try to use the sim900 GPRS library to connect to an MQTT server. It opens a TCP socket but it writes empty buffer. Let me know if you were able to find a solution.


You need to log in to post a question