5 years, 3 months ago.

mbed HDK

Hi all,

I have recently designed a board using the LPC1768 HDK including the LPC11U35 interface. I have downloaded the relevant bin file to the interface chip and when I plug the USB in the board now acts the same as an mbed. However when I download a bin file, the USB drive disconnects and reconnects without the bin file but with a .trash file inside (and a couple of other strange files) as well as the mbed.htm. Also the program I download doesn't run, it's like the LPC1768 either doesn't hold the program or the chip resets before full download.

Is there any drivers or updates required? has anyone else seen this sort of behaviour with the MDK? One thing I did notice is on the MDK is that SDO is a single net note from the interface and it isn't connected to the LPC1768.

One last thing is every now and again if I delete all files, including the mbed.htm, then program with a bin file, I can sometimes get the program to run for a very short period of time but when I power cycle the bin file has disappeared and a timeout fail.txt appears.

I have tried a different USB cable as I realise this does sound like a poor connection somewhere along the line, however I was just wondering if anybody could shed any light on something else I may be missing.

Thanks in advance,

Kyle.

The interface firmware in that repo is quite old. I'll re-build the firmware and update the repo tomorrow. Also - board will always eject when programming completes. There isn't storage for a file-system. The firmware presents a virtual file-system and programs the target while the data is transferred across USB. If an error occurs the fail.txt file will be on the drive with a description of the problem. Otherwise, pressing the reset button should boot the binary that was downloaded onto the target.

posted by Sam Grove 11 Aug 2014

Hi Sam, that would be great. Please can you let me know when it is updated. I solved the issue today, with thanks to Wim. The issue I had was that when the bin file is downloaded, the device connects and reconnects but a physical reset is still required. The reason I was getting strange files was because I had recently set my folder viewing options to show hidden file types! Turns out these weird files are on all of my Mbed devices and probably always have been! :-P

posted by Kyle Cassar 11 Aug 2014

The files have been updated. https://mbed.org/teams/mbed/code/mbed-HDK/graph

posted by Sam Grove 11 Aug 2014

Cheers.

posted by Kyle Cassar 11 Aug 2014

Just to let you know, this update fixed my reset issue. thanks again.

posted by Kyle Cassar 12 Aug 2014

Is the binary NXP/LPC1768/lpc11u35_lpc1768_if_mbed.bin

for the 501, or will it work in the 401,

I would like to use:

LPC11U35FBD48/401

because it has legs to solder to !!!!

If not is it possible to build a version that will work in the .. 401 chip ??

Cheers

Ceri

posted by ceri clatworthy 12 Aug 2014

Hi Ceri,

I can't answer your question about the 401, however what I did with the 501 was connect a pin to ground and route it to the land pad underneath. this way you can still hand solder the 501 part. The other thing you can do which is better in hindsight is to place via's, kapton tape the chip down and flow solder through the via's from the bottom of the board. Hand soldering the part isn't as bad as it looks.

posted by Kyle Cassar 12 Aug 2014

the issue is, that the '501 has 12K, of memory, whereas the '401 has 10K of memory.

and the HDK Software needs 12K

Ceri

posted by ceri clatworthy 14 Aug 2014
Comment on this question

1 Answer

5 years, 3 months ago.

The CMSIS-DAP interface does not have a local filesystem like the original mbed modules. So the mbed drive will not show the bin file file for the target device. The drive disconnects and reconnect when something goes wrong while flashing the target. There should be so file called failed.txt which provides more info. The target programming interface should include SWD-DIO, SWD-CLK and GND. The reset is optional but preferred. The SWD-SWO line is optional and not used by mbed. You may want to check programming the target through the serial interface and Flashmagic to make sure that the target HW is OK.

Hi Wim,

Thanks for the quick response. "The drive disconnects and reconnect when something goes wrong while flashing the target", this is very helpful, I didn't realise that. the only thing is there is no fail.txt when this occurs. I will give flashmagic a go tomorrow when I'm back in the workshop, I take it I will need to bring out the serial lines in order to do this as I won't be able to do it with a USB? I will give it a go and post my results.

posted by Kyle Cassar 10 Aug 2014

Breaking out the serial pins is probably best although the interface chip can be used as usb to serial converter assuming it works as supposed to. Note you still need to pull the ISP pin to the required level while resetting the target in order to get the target in ISP mode.

posted by Wim Huiskamp 10 Aug 2014