Report
5 years, 1 month ago.

VodafoneUSB library no longer compiles [EXTREMELY FRUSTRATING!]

I'm working on a project on which I'm using the Vodafone dongle. I've tried to compile the sample programs of the Vodafone Library I even tried importing older revisions of the library but I always get some compilation errors especially the message: "Identifier ip_input is undefined " in tcp.cp. It seems that some class or function is missing but I have no clue as to which file I have to include. This library used to work with no problem, I've been using it for almost 2 years. Why can't the idiots at ARM put a stable release? Why have you guys just left it like that making life harder for everyone else? I can't move forward in my project because of this.

Hello,

can you point us to the sample programs which do not build, share links, to be able to reproduce issues you are seeing.

posted by Martin Kojtal 04 Aug 2014

The hello world program http://mbed.org/cookbook/VodafoneUSBModem#hello-world doesn't compile. I found a very old version of the library that works and can be found here https://mbed.org/users/ashleymills/code/VodafoneSMSBasics/file/a98b70f27320/main.cpp

posted by David Fofana 04 Aug 2014
Comment on this question
Be the first to answer this question.

You need to log in to post a question