6 years, 1 month ago.

USBSerial with Flash Magic (LPC11U35)

I'm trying to use a LPC11U35 as a USB-serial adapter to flash my LPC1768 with Flash Magic (after picking the wrong variant of the U35 to run the HDK). I installed the driver using the .inf file provided. Using Tera Term, I am able to communicate with the LPC1768 and get the expected responses (?->Synchronized. etc.), but when I run Flash Magic, I get the failed to autobaud error. I also get no response within the Flash Magic terminal. I can see with my scope that the LPC1768 is responding as it should, even when using Flash Magic, implying that my issue is software. I have tried this on 2 different computers to the same result. Has anyone else had this issue? Are there any other drivers that I can try?

Question relating to:

RESOLVED: The latest version of Flash Magic (8.18.3612) implements a fix for this issue, just make sure to enable 'Disable DTR and RTS completely" under the Hardware Config tab in Advanced Options.

posted by Jason T 25 Jul 2014
Be the first to answer this question.