Report
5 years, 2 months ago.

Problem installing upload program on board (nucleo STM32F401)

Hi, I'm on windows 8 and my nucleo board show 0 bytes of free space so i can't upload program on it.

/media/uploads/rickorpse/nucleo_bug.jpg

Any idea of the problem?

Thank

Question relating to:

ST
A world leader in providing the semiconductor solutions that make a positive contribution to people’s lives, both today and in the future.

what's the version of firmware on your ST board?

posted by Martin Kojtal 16 Jun 2014

judging by the size of memory is the problem with the drivers.

posted by Sergey Kordubin 17 Jun 2014
Comment on this question

3 Answers

4 years, 9 months ago.

have you fixed ? I have the same problem !!

4 years, 9 months ago.

You need to upgrade the firmware on your board. This is a known issue with the ST 401 boards. Please follow the instructions here http://developer.mbed.org/teams/ST/wiki/Nucleo-Firmware

-Austin

You won't believe what was the solution for me : I had one sensor connected PB_7 was pulling it down. When I have removed that one , board has started to work correctly.

posted by Daniel Dumitru 29 Oct 2014
5 years, 2 months ago.

Привет, подробнее опиши почему это произошло.

приведи код который ты загрузил.

попробуй вот эту программу - STM32 ST-LINK Utility, с ее помощью ты можешь очистить память процесора.

привет из России =).

Hi, describe in detail why this happened.

the code that you downloaded.

try this program here - STM32 ST-LINK Utility, with its help you can clear the memory of the CPU cycles.

Greetings from Russia =).

posted by Sergey Kordubin 17 Jun 2014

You need to log in to post a question