5 years, 4 months ago.

F401RE - SWD ERROR

Hi,in

After flashing a program to my board, I can't erase the memory or reflash any new by using explorer, CoIDE or Keil uVision4. In the explorer there are a fail.txt file which contains 'SWD ERROR' message.

Comment on this question

7 Answers

5 years, 3 months ago.

I've had this. At the same time I noticed that the device showed as having a capacity of about 28K and was full, not the 512K that was supposed to be there. I tried to reformat as per the instructions elsewhere, but got a moan about insufficient size (I think). Anyway, after re-plugging the nucleo I got a full size drive again. After that I upgraded the nucleo firmware under Windows and all has been ok since. I should say that I run a Manjaro/KDE4/64-bit system.

4 years, 6 months ago.

Hello,

I've had the same problem, after a wrong handling (the board has been touched by another one). So, I got SW ERROR (in a texte file). This error means that the first part of the board (where the USB is) cannot communicate with the second part (STM32). So, in my case there is no solution to repair it.

5 years, 3 months ago.

having the same problem. up'd the firmware with no luck. I had down loaded about 20 programs and had no problem.

defective? This is crazy.

4 years, 7 months ago.

Hi All, this morning I have the same problem on 2 board F401RE and F411RE.

When I plug them into usb port I can see a text file named fail.txt with SWD ERROR inside.

I've just updated the firmware but the problem is unsolved.

PLEASE HELP!

When you get strange errors like this you want to try the STLink utility to erase the target and reflash it with a simple blinky program and then retry the mbed drag and drop. See here for software and instruction manual.

posted by Wim Huiskamp 19 Mar 2015

Hi Wim, thank for your reply. My problem was AVDD, I've removed SB57 to test an external reference for the ADC. Then I've removed that reference without reconnect SB57. And that's the error. The Nucleo Board doesn't work without AVDD correctly connected to a voltage reference.

posted by Gigi Marz 31 Mar 2015
4 years, 10 months ago.

Same problem here

4 years, 10 months ago.

Same problem with Nucleo F302R8, It. go in 'SWD ERROR' status in random situation. Update of firmware do not resolve the issue. Only availabe option up to now is plug and unplug many times. I discover that the error appear rarely if WebBrowser is closed...

4 years, 10 months ago.

Have you tried pressing and holding the reset button B2 for a while before attempting to flash the target F302. Seems like the SWD programming interface has become non-responsive. Possibly caused by the last software that you downloaded. In case none of this helps you may have to go back to original STLINK programmer software, erase target memory and then reload mbed firmware.

I try many combinations with B1 and B2 :-)))) no result. erase target memmory reload firmware... it is to complicated and time consuming to me if I have to erase memmory and reload firmware every time when I need to load the program in Nucleo... I just will stop use Nucleo :-))))). I expect just Nucleo to work without troubles. and work with Nucleo to be easy. :-)))))

posted by Roumen Likov 18 Dec 2014

You need to log in to post a question