5 years, 6 months ago.

Target program does not download to nRF51822 mKit in Windows 8.1

Hi.

On Windows 8.1, if I download the hex file directly on mbed drive, the target does not work. But if I first save it to the desktop, and then I drag him on the mbed drive, then it works fine.

The HW seems to be OK.

  • SW4 is in ON position
  • SW5 also is in ON position
  • On R15 and R16, if I push SW3 (reset), the signals from ARM to the nRF51 chip is present (with oscilloscope) and i think that my program was sent to target.

The firmware seems to be running

  • The mBed drive is visible on Windows 8.1 and work fine.
  • The Windows 8.1 COM exists (COM9)
  • The green led is ON.
  • When I download my program from mBed IDE, the green led blink.

I've tried using different sources... from Blink to BLE_HeartRate and BLE_Beacon. I've tried using different browser (Windows 8.1 IE, Chrome...)

Thank you!

Comment on this question

1 Answer

5 years, 6 months ago.

Hi Maurizio,

This is related to the placeholder files IE and Chrome place (which have extensions other than .hex) while downloading. There might be an update coming that copes with these, but in the meanwhile you should be able to use Firefox for this purpose.

Yes! This is true. I tried with Firefox and it works. Thank you.

posted by Maurizio Conti 10 May 2014