5 years, 6 months ago.

STM32F401RE Nucleo - Virtual COM Port is not working properly

Hello there,

I've been using the Nucleo for some time, and I found out there is a problem with the VIrtual COM port. I used a sample test program from the library (printf) and any of the terminal software I've used does not show any output despite the Virtual COM Port is detected. However, when I used an external USB->UART converter (available cheaply in your local stores), and jumper the converter's RX pin to the CN3's RX pin, I see the output clearly. The funny thing is, is the CN3's RX pin a TX pin? I felt that this has printed wrongly on the board.

Here's the steps I've done:

1.) Installed the Virtual COM Port Drivers (VCP 1.3.1) and reinstalled it. 2.) Tested with all different libraries of printf, and it didn't do much - detected but not getting outputs or inputs.

Is the UART module in the ST-Link on the board not working? Or did I miss something here?

Thanks, N.

Question relating to:

Affordable and flexible platform to ease prototyping using a STM32F401RET6 microcontroller.

I've found that it does work, but only about 1/10 times

posted by Eric Wieser 30 Mar 2014

Hello,

I tried plugging it in my Win8 laptop, and with the drivers installed, and it worked flawlessly.

On the other Win7 laptop, it behaves in an erratic manner initally, and then after that behaves exactly like my main computer.

Is it the driver problem for Win7, or is it the Virtual COM Port (and its drivers) not optimized for Nucleo?

Thanks, N.

posted by Y.H. NG 30 Mar 2014
Comment on this question

4 Answers

3 years, 6 months ago.

Have the same problem with two NECLEO boards - F401RE and F103RB. Simptoms are the same - i can send letters from terminal through virtual com port and nothing comes out of virtual com port. Used oscilograph to track signals and all seems correct on CN3 connector, so all signals are going to V-Link part, USB sniffer shows that no packets at all are coming from virtual com port. Tried to reinstall drivers and upgrade firmware. Now I can only use this boards connecting PL2303 converter to Serial1 or Serial2 pins - all is ok at high speeds. But this is not very convenient to have two USB connections - one for programming and one for debug terminal.

So long as this problem is the same for two differecnt NUCLEO boards (bought from SeeedStudio half year ago), it looks like some open V-Link firmware or driver problem.

Update: tried it on PC with x86 Win7 and it fully works. So this problem with high probability can be localized to amd64 driver version.

Did you ever solve this problem - how? I am having the same issue. Thanks, jon.perrin@glacierriver.com

posted by Jon Perrin 26 May 2016
5 years, 6 months ago.

I'm not using the VCP 1.3 drivers, the Nucleo board has it's own driver set, and the USART connection is working fine on the F401RE board.

http://www.st.com/web/catalog/tools/FM147/SC1887/PF260218

http://www.st.com/web/catalog/tools/FM147/SC1887/PF260219

http://www.st.com/web/catalog/tools/FM147/SC1887

Using Win7 x64, reporting in Device Manager - Ports

STMicroelectronics STLink Virtual COM Port (COM12)

STMicroelectronics

12/10/2013

1.0.0.0

Also install the current firmware (2.19.3) for the Nucleo ST-LINK

http://www.st.com/web/catalog/tools/FM147/SC1887/PF260217

Hello,

Thanks for the answer, but I've tried all of these already too - and the Nucleo's Virtual COM port still doesn't respond. It happened that probably the USB drivers in my current desktop computer is acting up as my only Win8 laptop worked fine with it.

Thanks, N.

posted by Y.H. NG 01 Apr 2014

So what actually shows up in Device Manager? Some unidentified device with an exclamation mark, or some device, with some version number?

According to Win7 the driver is reportedly signed, so that shouldn't be an issue. The old VCP driver was very sensitive to being installed appropriately on a 32 or 64-bit system. Code 10 message as I recall.

May be the issue is at the mbed end? I've test the USART with code running directly on the STM32.

posted by Clive Turvey 01 Apr 2014

Hello,

Whatever about the Virtual COM Port in the Device Manager is identical to your earlier answer. All the drivers are in good condition and they are installed properly. My Win7 installation is 64-bit and the drivers for all the ST-related products are latest.

Thanks, N.

posted by Y.H. NG 01 Apr 2014
4 years, 6 months ago.

Hello. I have the same problem in linux. The Serial pc comunications works 1/10 or even less. Sometimes it works. The rest of functions look work properly.

3 years, 8 months ago.

It doesn't appear that the ST USB Composite drivers work when the F401RE is plugged into a USB3.0 port. Seems to work fine in a USB2.0 port only. All other drivers load properly on a USB3.0 port.

/media/uploads/ARROWFAE/capture.png


You need to log in to post a question