6 years, 4 months ago.

Regarding the problem of board setup

Hi All, I try to use online compiler of mbed. I am using STM32, Nucleo-F302R8. I am novice in this sector.

And the problem is when I try to complie the code then it shows a error and code cant be downloaded. The error shows that, "Target "ST_PLACEHOLDER" is not recognized". I cant understand that how can I solve it.

It would be great for me if anyone help me to solve this problem. I would highly appreciate your effort.

Thanks in advance, Torongo

What are you trying to compile? Is your mbed lib up to date? (Click on it, click update at right side).

posted by Erik - 28 Feb 2014

Its a simple Led blink program. And I all do it by online compiler and get this error. So, how can I solve this problem ?? Thanks in advance.

posted by Md. Istiaq Mahbub 28 Feb 2014

Did you try updating your mbed lib?

posted by Erik - 28 Feb 2014

I know its a silly question. But I am not sure how can I update it? Can you tell it pls.

posted by Md. Istiaq Mahbub 28 Feb 2014

See my first comment: Click on it, click update at right side

posted by Erik - 28 Feb 2014

Click on it, what ? I dont see any hyperlink or something where I can click for download? Can you mention more specific?

posted by Md. Istiaq Mahbub 28 Feb 2014

Another thing, I used F302R8. If i choose F030R8 then the bin file is downloaded without any problem. Is it any problem for F302R8?

posted by Md. Istiaq Mahbub 28 Feb 2014
Be the first to answer this question.