7 years, 7 months ago.

Win 8.1 x64 No Mbed unless Bootloader Mode

Hello,

I did all the firmware upgrades and even tried an older one. 8.1 does NOT see the device upon plug and not even in the device manager.

If I hold down the button, then plug in then the device is recognized and mounted as BOOTLOADER.

Any suggestions?

Device: KL25Z

2 Answers

7 years, 7 months ago.

I think freescale and PE Micro has forgotten that quite a few of us have newer computers to develop on. Ouch.

The USB drivers and support software on most of the boards does not contain the fixes required.

It works fine on Win7, just follow the docs, and update Microbooter, and other firmware using downloads from Freescale and PE Micro.

After that it works like a charm on win 8.1. If you are completely updated on firmware there should be no problems with the board I think.

You write that you press the button when powering up, according to the docs you should only press the button when updating firmware, and NOT when putting on a new mbed bin file. Mbed programming is just:

1. boot the board, and a drive pops up on your machine (MBED its called) 2. Compile and copy your binary to the drive. 3. Click RST button (between the mini-usb plugs) and its loads your bin. (no need to power-cycle)

Does it work?

7 years, 7 months ago.

Hi, i had this issue with the frdm-kl46z board. For me what worked was to press and hold the RST button during the whole firmware update procedure. then unplug it and replug and it behaved like a normal mbed after that. Hope it helps you