9 years, 1 month ago.

Mbed reset malfuction and disconnect after connect Teraterm

Dear All,

Recently i'm testing CMSIS-DAP debug. The testing is done successfully.

As usual practice use online IDE compiler compile and download the .bin to Mbed drive then press Reset. It work fine until this state and double check the .bin file is saved in Mbed drive. But after connect Teraterm, the Mbed reset malfunction (communication LED is not switch OFF after reset is pressed) and MyComputer open Mbed drive but not able to open seem like device is hang. Have to unplug the USB cable then plug it back then the reset function again but still can't open Teraterm. I have tried to format the drive but eventually still the same.

Is it i have to down grade the Mbed firmware?

Best Regards, Wq

WHat is your target? CAn you share the application? My guess would be that you are accessing pins which are shared between an interface chip and a target, which can lead to malfunction.

posted by Martin Kojtal 12 Feb 2014

May i know what target do you mean? Mbed LPC1768?

What application do you mean? Do you mean the Coding?

Mbed is working fine before CMSIS-DAP test. CMSIS-DAP is request to upgrade the firmware of Mbed. If i not mistake before upgrade to rev 141212 is rev 16457.

posted by Wen qian 12 Feb 2014
Be the first to answer this question.