5 years, 11 months ago.

Any way to use an mbed device through Chrome OS?

Any way to use an mbed device through Chrome OS?

Just tried it with Acer C720 Chromebook.

Downloads just fine. Does give warning as to making sure to eject removable device before unplugging it, but board seems fine. Tried it with FRDM-KL25Z and blink LED standard program. Will be trying with more complex code later on.

Very cool as Arduino IDE won't work on my Chromebook without parallel installing Ubuntu....

posted by Daniel Hadad 27 Oct 2014
Comment on this question

2 Answers

5 years, 11 months ago.

I believe someone else asked it once and eventually found out it just worked fine, but I cannot really find it anymore, so maybe I am confusing stuff.

But do you have ChromeOS? In that case, just try it. I *expect* programming to work, in the end it is simply an USB drive, and I assume ChromeOS can use those. The serial USB connection will be a possible problem.

Thanks, I'll give it a shot. The reason I tried was because on my Chromebook it won't load any BIN files. I'll try just copying it over and see if that works

posted by Daniel Newberry 15 Dec 2013

You mean opening the bin files on your chromebook? That also shouldn't work ;). Just copy it over to the mbed disk should do the trick.

Edit: Chromebook is what I had to use for the search instead of chromeos, see: http://mbed.org/questions/1385/Samsung-Chromebook/. He has a KL25Z, so the unlocking part can be skipped for the LPC1768.

posted by Erik Olieman 15 Dec 2013

Thanks man for all your help :)

posted by Daniel Newberry 15 Dec 2013
5 years, 11 months ago.

I have a ChromeOS running on a Dell Studio 1535, to test if I can switch to a Chromebook. The mbed compiler works fine and saves the .bin file to the Downloads directory, and my LPC1768 mbed device appears in "Files" but the files are not visible on it. The only right-click options are "format device" and "eject device." I'm afraid to do either because I don't want to brick my mbed.

For me, that's "NO" to using mbed on Chromebook. I just read that Chromebook has grabbed 20% of laptop market in form 0% a year ago, and most of them are going into education.

Formatting device shouldn't result in problems, but at the same time it should list the files so I understand your reluctance. However since someone else (see link above) did manage to get it working, and in the end it is just a mass storage device, so it should work. In theory :P

posted by Erik Olieman 03 Jan 2014

OK, I tried the format option and it didn't help. Updating the mbed firmware didn't either. Files in other USB drives are invisible too. My ChromeOS is probably messed up.

posted by Peter Allan 03 Jan 2014