6 years, 3 months ago.

Serial Communciation Problems

Hi,

One day suddenly mbed has stopped "opeing port ttyACM0"

Previously resetting mebd several times resolved this issue. But I have tried so many things now to resolve this. Can any one help me with this issue.

I have tried to use the following: 1. Different OS: From Ubuntu 12 to Ubuntu 13.1 2. Changed the serial port settings baud rate etc 3. Offline compilation gcc4mbed 4.Tried to connect a different mbed, changed the USB wire

Some of above things made it work for some time but When mbed is stucked not even a sample Hello world program has run on it.

Your ehlp will be much appreciated as I almost gaveup to resolve it

2 Answers

6 years, 3 months ago.

Check your permissions. Try sudo chmod 775 ttyACM0 in the /dev directory.

Hi , I have tried the command in /dev directory and it said "chmod: cannot access `ttyACM0': No such file or directory"

posted by Newbie Student 10 Dec 2013
6 years, 3 months ago.

I tried to install Linux Mint (maya) after trying so many things and apparently things started working. its noticable that serial communciation was not working good with Ubuntu distribustions.

But today again .. the serial communication is giving same problems.

Do anyone has some idea whats going wrong here??

Have you tried changing the ownership of /dev/ttyACM0 from root to your user? I found I needed to do this in order to get the comms to work. I think it would read something like this

sudo chown <user> /dev/ttyACM0

posted by Rob Cawsey 13 Dec 2013

Sound silly, but try another usb cable. The quality of cables coming out of China is beyond. Absolute rubbish. I have had to ditch numerous cables because of this. I think you'll find there is nothing wrong with the Linux distros.

posted by mathew roberts 13 Dec 2013