5 years, 11 months ago.

USB Bootloader LPC11U24

Hi all,

I have just made a custom PCB for the 48 pin LPC11U24. I built it up today and it all worked too easily (always skeptical). The target enumerated as a mass storage device with a firmware file in. I deleted the firmware file and placed a test program (blinky) into the target. This is running with no problems. My issue is that now my program is running I cannot get my PC to detect the target again to reprogram. Does anybody know if there is a reason for this? There's a possibility it's a hardware fault but I'm surprised that the board worked with no problems originally.

Thanks in advance for any help received.

Kyle.

Comment on this question

2 Answers

5 years, 11 months ago.

Hi Kyle.

You have to choose ISP mode, by grounding P0.1 (pin 4 on LPC11U24FBD48), and then reset.
Also, you can choose between serial or USB bootloader using P0.3 (pin 14). By pulling up this pin, you should
get access to the USB bootloader.

Hopes this helps you.
Lerche

Hello again Lerche,

I thought I had this covered in my circuitry, however I went through it and measured the ISP pin and for some reason this is not being pulled low. I shorted the pin to ground and this did work! I will have to look through my schematic tonight and work out why my switch isn't working. I used your footprint (for the 48 pin LPC11) and it's absolutely spot on, I will post pictures of my board once I sort my circuitry and order an issue 2 :-). Thanks a lot for quick reply and footprint, it is very much appreciated.

Kyle.

posted by Kyle Cassar 30 Nov 2013

No problem Kyle,
We all helping each other out here :-)
Lerche

posted by Christian Lerche 02 Dec 2013
Kyle Cassar
poster
5 years, 11 months ago.

Hello Lerche,

I had a placed a diode in the wrong orientation meaning the ISP would not pull to ground. How did you find the translation from 64 pin package to 48? Can you use pretty much any program you have written for the 64 pin in the compiler or are there any configurations that need amending, e.g. pin names etc... /media/uploads/cassar10/img_0410-1-.jpg I have uploaded a picture of the current board, mainly because I've never updated a photo!

cheers,

Looking great :D
Yes, the software doesnøt mind that you're using the 48 pin version. Actually, it's just the ports inside that isn't connected.
And the way I found out, was that I tested it. Etched a PCB, soldered, tested. Worked as expected.

Lerche

posted by Christian Lerche 02 Dec 2013